High
Security advisory
etcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users' passwords with little computational effort.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-15115
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:52 UTC · Revision 1
Source evidence
etcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users' passwords with little computational effort.
osv:CVE-2020-15115
Complete source record
{
"id": "b0a8b8eccd7badf162c89299f5163c3e095b3fd2cbfb9cb39797b753b281724f",
"url": "https://osv.dev/vulnerability/CVE-2020-15115",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-15115",
"summary": "etcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users' passwords with little computational effort.",
"evidence": "osv:CVE-2020-15115",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2020-15115",
"aliases": [
"CVE-2020-15115",
"GHSA-4993-m7g5-r9hh"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/etcd-io/etcd",
"type": "GIT",
"events": [
{
"introduced": "c23606781f63d09917a1e7abfcefeb337a9608ea"
},
{
"fixed": "4873f5516bd98c82dddb81247038337f25abac4e"
},
{
"introduced": "898bd1351fcf6e0ebce8d7c8bbbbf3f3e42aa42c"
},
{
"fixed": "18dfb9cca345bb2b2fbe73d5fc31028c2477bef1"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:redhat:etcd:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.3.0"
},
{
"fixed": "3.3.23"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:redhat:etcd:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.4.0"
},
{
"fixed": "3.4.10"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.3.22",
"v3.4.9",
"v3.4.8",
"v3.3.21",
"v3.3.20",
"v3.4.7",
"v3.3.19",
"v3.4.6",
"v3.4.5",
"v3.4.4",
"v3.3.18",
"v3.4.3",
"v3.3.17",
"v3.3.16",
"v3.4.2",
"v3.4.1",
"v3.4.0",
"v3.3.15",
"v3.3.14",
"v3.3.14-rc.0",
"v3.3.14-beta.0",
"v3.3.13",
"v3.3.12",
"v3.3.11",
"v3.3.10",
"v3.3.9",
"v3.3.8",
"v3.3.7",
"v3.3.6",
"v3.3.5",
"v3.3.4",
"v3.3.3",
"v3.3.2",
"v3.3.1",
"v3.3.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-15115.json"
}
}
],
"modified": "2026-10-20T10:51:51.999209512Z",
"provider": "osv",
"references": [
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L6B6R43Y7M3DCHWK3L3UVGE2K6WWECMP/",
"https://github.com/etcd-io/etcd/security/advisories/GHSA-4993-m7g5-r9hh"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*"
],
"vendor_product": "fedoraproject:fedora",
"extracted_events": [
{
"range": [
{
"introduced": "32"
},
{
"last_affected": "32"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2020-15115",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 383043,
"published_at": "2020-08-06T22:15:12.093+00:00"
}