jqueryui — security advisory
jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of the `altField` option of the Datepicker widget from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `altField` option is now treated as a CSS selector. A workaround is to not accept the value of the `altField` option from untrusted sources.
- Products
- jqueryui
- Affected versions
- Not specified
- Fixed versions
- 1.13.0+dfsg-1
- CVEs
- CVE-2021-41182
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:44 UTC · Revision 1
Source evidence
jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of the `altField` option of the Datepicker widget from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `altField` option is now treated as a CSS selector. A workaround is to not accept the value of the `altField` option from untrusted sources.
osv:DEBIAN-CVE-2021-41182
jqueryui
Fixed versions: 1.13.0+dfsg-1
jqueryui
Fixed versions: 1.13.0+dfsg-1
jqueryui
Fixed versions: 1.13.0+dfsg-1
Complete source record
{
"id": "ca2949dd687cc110adbbe30cecb294d5ad20837482f971879d9d7b0609289511",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-41182",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-41182",
"summary": "jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of the `altField` option of the Datepicker widget from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `altField` option is now treated as a CSS selector. A workaround is to not accept the value of the `altField` option from untrusted sources.",
"evidence": "osv:DEBIAN-CVE-2021-41182",
"products": [
{
"name": {
"value": "jqueryui",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.0+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "jqueryui",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.0+dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "jqueryui",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.0+dfsg-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2021-41182",
"aliases": [
"DEBIAN-CVE-2021-41182"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.0+dfsg-1"
}
]
}
],
"package": {
"name": "jqueryui",
"purl": "pkg:deb/debian/jqueryui?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-41182.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.0+dfsg-1"
}
]
}
],
"package": {
"name": "jqueryui",
"purl": "pkg:deb/debian/jqueryui?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-41182.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.0+dfsg-1"
}
]
}
],
"package": {
"name": "jqueryui",
"purl": "pkg:deb/debian/jqueryui?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-41182.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:38.808041529Z",
"provider": "osv",
"upstream": [
"CVE-2021-41182"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-41182"
]
},
"related_cves": [
{
"value": "CVE-2021-41182",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 422120,
"published_at": "2021-10-26T15:15:10.313+00:00"
}