Skip to content
Heist/ feed
Back to feed
MediumFix available

wordpress — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2018-10101

Before WordPress 4.9.5, the URL validator assumed URLs with the hostname localhost were on the same host as the WordPress server.

Products
wordpress
Affected versions
Not specified
Fixed versions
4.9.5+dfsg1-1
CVEs
CVE-2018-10101
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 00:03 UTC · Revision 1

Source evidence

DEBIAN-CVE-2018-10101

core-osv · Original source

Published 16 Apr 2018, 09:58 UTC

Before WordPress 4.9.5, the URL validator assumed URLs with the hostname localhost were on the same host as the WordPress server.

osv:DEBIAN-CVE-2018-10101

wordpress

Fixed versions: 4.9.5+dfsg1-1

wordpress

Fixed versions: 4.9.5+dfsg1-1

wordpress

Fixed versions: 4.9.5+dfsg1-1

Complete source record
{
  "id": "443ef9286e3efaf617fefd4a19ee3b4735a92406bc5d597809df148d28e8e4a9",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-10101",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2018-10101",
    "summary": "Before WordPress 4.9.5, the URL validator assumed URLs with the hostname localhost were on the same host as the WordPress server.",
    "evidence": "osv:DEBIAN-CVE-2018-10101",
    "products": [
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.9.5+dfsg1-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.9.5+dfsg1-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "wordpress",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.9.5+dfsg1-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2018-10101",
      "aliases": [
        "DEBIAN-CVE-2018-10101"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4.9.5+dfsg1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-10101.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4.9.5+dfsg1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-10101.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4.9.5+dfsg1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "wordpress",
            "purl": "pkg:deb/debian/wordpress?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-10101.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:02:56.064513585Z",
      "provider": "osv",
      "upstream": [
        "CVE-2018-10101"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2018-10101"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2018-10101",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 419839,
  "published_at": "2018-04-16T09:58:09.62+00:00"
}