erlang-cowlib — security advisory
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in ninenines cowlib allows unauthenticated remote denial of service via memory exhaustion. cow_spdy:inflate/2 in cowlib passes peer-supplied compressed bytes directly to zlib:inflate/2 with no output size bound. The SPDY header compression dictionary (?ZDICT) is public, and zlib compresses long runs of repeated bytes at roughly 1024:1, so a few kilobytes of SPDY frame payload can decompress to gigabytes on the BEAM heap, OOM-killing the node. A single unauthenticated SPDY frame is sufficient to trigger the condition. The parsers for syn_stream, syn_reply, and headers frame types are all affected via cow_spdy:parse_headers/2. This issue affects cowlib from 0.1.0 before 2.16.1.
- Products
- erlang-cowlib
- Affected versions
- 1.3.0-3, 2.17.1-1, 2.17.1-2, 2.18.0-1, 2.19.0-1, 2.20.0-1, 2.21.0-1
- Fixed versions
- 2.17.1-1
- CVEs
- CVE-2026-43970
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:50 UTC · Revision 2
Source evidence
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in ninenines cowlib allows unauthenticated remote denial of service via memory exhaustion. cow_spdy:inflate/2 in cowlib passes peer-supplied compressed bytes directly to zlib:inflate/2 with no output size bound. The SPDY header compression dictionary (?ZDICT) is public, and zlib compresses long runs of repeated bytes at roughly 1024:1, so a few kilobytes of SPDY frame payload can decompress to gigabytes on the BEAM heap, OOM-killing the node. A single unauthenticated SPDY frame is sufficient to trigger the condition. The parsers for syn_stream, syn_reply, and headers frame types are all affected via cow_spdy:parse_headers/2. This issue affects cowlib from 0.1.0 before 2.16.1.
osv:DEBIAN-CVE-2026-43970
erlang-cowlib
Fixed versions: Not specified
erlang-cowlib
Fixed versions: Not specified
erlang-cowlib
Fixed versions: 2.17.1-1
Complete source record
{
"id": "b90a7730417b940b2b7f6d6597a468ad8a535d2f1aef356202fd434ff48eb9d2",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-43970",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-43970",
"summary": "Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in ninenines cowlib allows unauthenticated remote denial of service via memory exhaustion. cow_spdy:inflate/2 in cowlib passes peer-supplied compressed bytes directly to zlib:inflate/2 with no output size bound. The SPDY header compression dictionary (?ZDICT) is public, and zlib compresses long runs of repeated bytes at roughly 1024:1, so a few kilobytes of SPDY frame payload can decompress to gigabytes on the BEAM heap, OOM-killing the node. A single unauthenticated SPDY frame is sufficient to trigger the condition. The parsers for syn_stream, syn_reply, and headers frame types are all affected via cow_spdy:parse_headers/2. This issue affects cowlib from 0.1.0 before 2.16.1.",
"evidence": "osv:DEBIAN-CVE-2026-43970",
"products": [
{
"name": {
"value": "erlang-cowlib",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.3.0-3",
"evidence": "/affected/0/versions"
},
{
"value": "2.17.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.17.1-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.18.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.19.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.20.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.21.0-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "erlang-cowlib",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.3.0-3",
"evidence": "/affected/1/versions"
},
{
"value": "2.17.1-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.17.1-2",
"evidence": "/affected/1/versions"
},
{
"value": "2.18.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.19.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.20.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.21.0-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "erlang-cowlib",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.17.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "1.3.0-3",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-43970",
"aliases": [
"DEBIAN-CVE-2026-43970"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "erlang-cowlib",
"purl": "pkg:deb/debian/erlang-cowlib?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.3.0-3",
"2.17.1-1",
"2.17.1-2",
"2.18.0-1",
"2.19.0-1",
"2.20.0-1",
"2.21.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-43970.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "erlang-cowlib",
"purl": "pkg:deb/debian/erlang-cowlib?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"1.3.0-3",
"2.17.1-1",
"2.17.1-2",
"2.18.0-1",
"2.19.0-1",
"2.20.0-1",
"2.21.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-43970.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.17.1-1"
}
]
}
],
"package": {
"name": "erlang-cowlib",
"purl": "pkg:deb/debian/erlang-cowlib?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.3.0-3"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-43970.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-27T10:01:40.726141003Z",
"provider": "osv",
"upstream": [
"CVE-2026-43970"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-43970"
]
},
"related_cves": [
{
"value": "CVE-2026-43970",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 461352,
"published_at": "2026-05-13T19:17:25.44+00:00"
}