HighFix available
vlc — security advisory
An integer overflow in the VNC module in VideoLAN VLC Media Player through 3.0.17.4 allows attackers, by tricking a user into opening a crafted playlist or connecting to a rogue VNC server, to crash VLC or execute code under some conditions.
- Products
- vlc
- Affected versions
- Not specified
- Fixed versions
- 3.0.18-1
- CVEs
- CVE-2022-41325
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:31 UTC · Revision 1
Source evidence
An integer overflow in the VNC module in VideoLAN VLC Media Player through 3.0.17.4 allows attackers, by tricking a user into opening a crafted playlist or connecting to a rogue VNC server, to crash VLC or execute code under some conditions.
osv:DEBIAN-CVE-2022-41325
vlc
Fixed versions: 3.0.18-1
vlc
Fixed versions: 3.0.18-1
vlc
Fixed versions: 3.0.18-1
Complete source record
{
"id": "747122ebda8edef9d7181a0adfbcb661c3755258be1160fca505f4e91ba7d287",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-41325",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-41325",
"summary": "An integer overflow in the VNC module in VideoLAN VLC Media Player through 3.0.17.4 allows attackers, by tricking a user into opening a crafted playlist or connecting to a rogue VNC server, to crash VLC or execute code under some conditions.",
"evidence": "osv:DEBIAN-CVE-2022-41325",
"products": [
{
"name": {
"value": "vlc",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.18-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "vlc",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.18-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "vlc",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.18-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-41325",
"aliases": [
"DEBIAN-CVE-2022-41325"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.18-1"
}
]
}
],
"package": {
"name": "vlc",
"purl": "pkg:deb/debian/vlc?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-41325.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.18-1"
}
]
}
],
"package": {
"name": "vlc",
"purl": "pkg:deb/debian/vlc?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-41325.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.18-1"
}
]
}
],
"package": {
"name": "vlc",
"purl": "pkg:deb/debian/vlc?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-41325.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:03:05.551478330Z",
"provider": "osv",
"upstream": [
"CVE-2022-41325"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-41325"
]
},
"related_cves": [
{
"value": "CVE-2022-41325",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 325118,
"published_at": "2022-12-06T16:15:11.173+00:00"
}