High
WordPress WP ERP plugin <= 1.13.2 - Reflected Cross Site Scripting (XSS) vulnerability
Type: advisorySources: OSV
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in weDevs WP ERP erp allows Reflected XSS.This issue affects WP ERP: from n/a through <= 1.13.2.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-47640
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 15:22 UTC · Revision 1
Source evidence
WordPress WP ERP plugin <= 1.13.2 - Reflected Cross Site Scripting (XSS) vulnerability
core-osv · Original sourcePublished 29 Oct 2024, 13:10 UTC
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in weDevs WP ERP erp allows Reflected XSS.This issue affects WP ERP: from n/a through <= 1.13.2.
osv:CVE-2024-47640
Complete source record
{
"id": "7621f6c65257fac13032d6ae61a9278a78cea3655078eca6471e3ebfab903342",
"url": "https://osv.dev/vulnerability/CVE-2024-47640",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress WP ERP plugin <= 1.13.2 - Reflected Cross Site Scripting (XSS) vulnerability",
"summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in weDevs WP ERP erp allows Reflected XSS.This issue affects WP ERP: from n/a through <= 1.13.2.",
"evidence": "osv:CVE-2024-47640",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-47640",
"aliases": [
"CVE-2024-47640"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wp-erp/wp-erp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "76691b3ad0dabda39ca02f66d9f0fa1fb74f03bc"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wedevs:wp_erp:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.13.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.13.2",
"v1.13.1",
"v1.12.9",
"v1.12.8",
"v1.12.7",
"v1.12.6",
"v1.12.5",
"v1.12.3",
"v1.12.2",
"v1.12.1",
"v1.12.0",
"v1.11.3",
"v1.11.2",
"v1.11.1",
"v1.11.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-47640.json"
}
}
],
"modified": "2026-10-28T02:30:29.730360675Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/47xxx/CVE-2024-47640.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-47640",
"https://patchstack.com/database/Wordpress/Plugin/erp/vulnerability/wordpress-wp-erp-plugin-1-13-2-reflected-cross-site-scripting-xss-vulnerability?_s_id=cve"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Patchstack",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "1.13.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "ChangesAt"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/47xxx/CVE-2024-47640.json"
}
},
"related_cves": [
{
"value": "CVE-2024-47640",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 496779,
"published_at": "2024-10-29T13:10:18.991+00:00"
}