CriticalFix available
wolfssl — security advisory
In wolfSSL before 5.5.2, if callback functions are enabled (via the WOLFSSL_CALLBACKS flag), then a malicious TLS 1.3 client or network attacker can trigger a buffer over-read on the heap of 5 bytes. (WOLFSSL_CALLBACKS is only intended for debugging.)
- Products
- wolfssl
- Affected versions
- Not specified
- Fixed versions
- 5.5.3-1
- CVEs
- CVE-2022-42905
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:02 UTC · Revision 1
Source evidence
In wolfSSL before 5.5.2, if callback functions are enabled (via the WOLFSSL_CALLBACKS flag), then a malicious TLS 1.3 client or network attacker can trigger a buffer over-read on the heap of 5 bytes. (WOLFSSL_CALLBACKS is only intended for debugging.)
osv:DEBIAN-CVE-2022-42905
wolfssl
Fixed versions: 5.5.3-1
wolfssl
Fixed versions: 5.5.3-1
Complete source record
{
"id": "e5eb0ed3a7a9166005543a4cc167842db9a5a19d488137d1a6719d10a21dcb51",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-42905",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-42905",
"summary": "In wolfSSL before 5.5.2, if callback functions are enabled (via the WOLFSSL_CALLBACKS flag), then a malicious TLS 1.3 client or network attacker can trigger a buffer over-read on the heap of 5 bytes. (WOLFSSL_CALLBACKS is only intended for debugging.)",
"evidence": "osv:DEBIAN-CVE-2022-42905",
"products": [
{
"name": {
"value": "wolfssl",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.5.3-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "wolfssl",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.5.3-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2022-42905",
"aliases": [
"DEBIAN-CVE-2022-42905"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.5.3-1"
}
]
}
],
"package": {
"name": "wolfssl",
"purl": "pkg:deb/debian/wolfssl?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-42905.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.5.3-1"
}
]
}
],
"package": {
"name": "wolfssl",
"purl": "pkg:deb/debian/wolfssl?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-42905.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:45.502679081Z",
"provider": "osv",
"upstream": [
"CVE-2022-42905"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-42905"
]
},
"related_cves": [
{
"value": "CVE-2022-42905",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 324163,
"published_at": "2022-11-07T00:15:09.643+00:00"
}