Critical
Security advisory
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-23730
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 23:33 UTC · Revision 1
Source evidence
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.
osv:CVE-2024-23730
Complete source record
{
"id": "4081a4ef6f89ba1258d09503ae2f0b3c2335f31cae4f29798116119ccf2fedae",
"url": "https://osv.dev/vulnerability/CVE-2024-23730",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2024-23730",
"summary": "The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.",
"evidence": "osv:CVE-2024-23730",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2024-23730",
"aliases": [
"CVE-2024-23730",
"GHSA-297x-2qf3-jrj3",
"PYSEC-2026-393"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/run-llama/llama-hub",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "db8d42ba92369b78ff0b46ae4368801b2e1fea11"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "0.0.67"
}
],
"source": "DESCRIPTION"
},
{
"range": [
{
"fixed": "db8d42ba92369b78ff0b46ae4368801b2e1fea11"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v0.0.67"
},
{
"cpe": "cpe:2.3:a:llamahub:llamahub:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.0.67"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v0.0.64",
"v0.0.52",
"v0.0.49",
"v0.0.47.post1",
"v0.0.47",
"v0.0.46",
"v0.0.39"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-23730.json"
}
}
],
"modified": "2026-10-28T02:30:40.536201620Z",
"provider": "osv",
"references": [
"https://github.com/run-llama/llama-hub/blob/v0.0.67/CHANGELOG.md",
"https://github.com/run-llama/llama-hub/pull/841/commits/9dc9c21a5c6d0226d1d2101c3121d4f085743d52",
"https://github.com/run-llama/llama-hub/releases/tag/v0.0.67",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/23xxx/CVE-2024-23730.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-23730"
],
"provider_metadata": {
"cna_assigner": "mitre",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/23xxx/CVE-2024-23730.json"
}
},
"related_cves": [
{
"value": "CVE-2024-23730",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 508006,
"published_at": "2024-01-21T00:00:00+00:00"
}