Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-21298

Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier has a vulnerability which allows arbitrary path traversal via the Projects API. If the Projects feature is enabled, a user with `projects.read` permission is able to access any file via the Projects API. The issue has been patched in Node-RED 1.2.8. The vulnerability applies only to the Projects feature which is not enabled by default in Node-RED. The primary workaround is not give untrusted users read access to the Node-RED editor.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-21298
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:32 UTC · Revision 1

Source evidence

CVE-2021-21298

core-osv · Original source

Published 26 Feb 2021, 17:15 UTC

Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier has a vulnerability which allows arbitrary path traversal via the Projects API. If the Projects feature is enabled, a user with `projects.read` permission is able to access any file via the Projects API. The issue has been patched in Node-RED 1.2.8. The vulnerability applies only to the Projects feature which is not enabled by default in Node-RED. The primary workaround is not give untrusted users read access to the Node-RED editor.

osv:CVE-2021-21298
Complete source record
{
  "id": "82d4eaa73ceef76f0fd55f0f1806abc0f637615e2700b661436ec8e9f992d227",
  "url": "https://osv.dev/vulnerability/CVE-2021-21298",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-21298",
    "summary": "Node-Red is a low-code programming for event-driven applications built using nodejs. Node-RED 1.2.7 and earlier has a vulnerability which allows arbitrary path traversal via the Projects API. If the Projects feature is enabled, a user with `projects.read` permission is able to access any file via the Projects API. The issue has been patched in Node-RED 1.2.8. The vulnerability applies only to the Projects feature which is not enabled by default in Node-RED. The primary workaround is not give untrusted users read access to the Node-RED editor.",
    "evidence": "osv:CVE-2021-21298",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2021-21298",
      "aliases": [
        "CVE-2021-21298",
        "GHSA-m33v-338h-4v9f"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/node-red/node-red",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "23f0cd3a2610c68688ea1f04fd61e9b8f6982166"
                },
                {
                  "fixed": "74db3e17d075f23d9c95d7871586cf461524c456"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:nodered:node-red:*:*:*:*:*:node.js:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.2.8"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "74db3e17d075f23d9c95d7871586cf461524c456"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "23f0cd3a2610c68688ea1f04fd61e9b8f6982166"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "1.2.8"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.2.7",
            "1.2.6",
            "1.2.5",
            "1.2.4",
            "1.2.3",
            "1.2.0",
            "1.2.2",
            "1.2.1",
            "1.2.0-beta.1",
            "1.1.1",
            "1.1.0",
            "1.0.6",
            "1.0.5",
            "1.0.1",
            "1.0.0",
            "1.0.0-beta.4",
            "1.0.0-beta.3",
            "0.20.7",
            "0.20.6",
            "0.20.5",
            "0.20.4",
            "0.20.3",
            "0.20.2",
            "0.20.1",
            "0.20.0",
            "0.20.0-beta.5",
            "0.20.0-beta.3",
            "0.20.0-beta.2",
            "0.18.7",
            "0.18.6",
            "0.18.5",
            "0.18.4",
            "0.18.3",
            "0.18.2",
            "0.18.1",
            "0.18.0",
            "0.17.5",
            "0.17.4",
            "0.17.3",
            "0.17.2",
            "0.17.1",
            "0.17.0",
            "0.16.1",
            "0.16.0",
            "0.15.3",
            "0.15.2",
            "0.15.1",
            "0.15.0",
            "0.14.6",
            "0.14.5",
            "0.14.4",
            "0.14.3",
            "0.14.2",
            "0.14.1",
            "0.14.0",
            "0.13.4",
            "0.13.3",
            "0.13.2",
            "0.13.1",
            "0.13.0",
            "0.12.5",
            "0.12.4",
            "0.12.3",
            "0.12.2",
            "0.12.1",
            "0.12.0",
            "0.11.2",
            "0.11.1",
            "0.11.0",
            "0.10.10",
            "0.10.9",
            "0.10.8",
            "0.10.6",
            "0.10.4",
            "0.10.3",
            "0.10.2",
            "0.10.1",
            "0.10.0",
            "0.9.1",
            "0.9.0",
            "0.8.1",
            "0.8.0",
            "0.7.2",
            "0.7.1",
            "0.7.0",
            "0.6.0",
            "0.5.0",
            "0.4.0",
            "0.3.0",
            "v0.2.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21298.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:28.000217860Z",
      "provider": "osv",
      "references": [
        "https://www.npmjs.com/package/%40node-red/runtime",
        "https://github.com/node-red/node-red/releases/tag/1.2.8",
        "https://github.com/node-red/node-red/security/advisories/GHSA-m33v-338h-4v9f",
        "https://github.com/node-red/node-red/commit/74db3e17d075f23d9c95d7871586cf461524c456"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2021-21298",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 385393,
  "published_at": "2021-02-26T17:15:12.337+00:00"
}