Skip to content
Heist/ feed
Back to feed
Medium

SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs

Type: advisorySources: OSV

SpiceDB is an open source database system for creating and managing security-critical application permissions. In versions 1.49.0 through 1.51.0, when SpiceDB starts with log level info, the startup "configuration" log will include the full datastore DSN, including the plaintext password, inside DatastoreConfig.URI. This issue has been fixed in version 1.51.1. If users are unable to immediately upgrade, they can work around this issue by changing the log level to warn or error.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-40091
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 04:22 UTC · Revision 1

Source evidence

SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs

core-osv · Original source

Published 14 Apr 2026, 23:50 UTC

SpiceDB is an open source database system for creating and managing security-critical application permissions. In versions 1.49.0 through 1.51.0, when SpiceDB starts with log level info, the startup "configuration" log will include the full datastore DSN, including the plaintext password, inside DatastoreConfig.URI. This issue has been fixed in version 1.51.1. If users are unable to immediately upgrade, they can work around this issue by changing the log level to warn or error.

osv:CVE-2026-40091
Complete source record
{
  "id": "aba9013d37d34714457a5c1470116917dd546b2eb3264e27078a6cd66226f454",
  "url": "https://osv.dev/vulnerability/CVE-2026-40091",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs",
    "summary": "SpiceDB is an open source database system for creating and managing security-critical application permissions. In versions 1.49.0 through 1.51.0, when SpiceDB starts with log level info, the startup \"configuration\" log will include the full datastore DSN, including the plaintext password, inside DatastoreConfig.URI. This issue has been fixed in version 1.51.1. If users are unable to immediately upgrade, they can work around this issue by changing the log level to warn or error.",
    "evidence": "osv:CVE-2026-40091",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-40091",
      "aliases": [
        "CVE-2026-40091",
        "GHSA-jf4f-rr2c-9m58",
        "GO-2026-5465"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/authzed/spicedb",
              "type": "GIT",
              "events": [
                {
                  "introduced": "10cc7f72eca3b47bb911bf1f50c701c1dc7d47e1"
                },
                {
                  "fixed": "add1e28b8701f9fa14c16db9181c0beab5f7109a"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "1.49.0"
                      },
                      {
                        "fixed": "1.51.1"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "add1e28b8701f9fa14c16db9181c0beab5f7109a"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v1.51.1"
                  },
                  {
                    "cpe": "cpe:2.3:a:authzed:spicedb:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "1.49.0"
                      },
                      {
                        "fixed": "1.51.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.51.0",
            "v1.50.0",
            "v1.49.2",
            "v1.49.1",
            "v1.49.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-40091.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:26.059267612Z",
      "provider": "osv",
      "references": [
        "https://github.com/authzed/spicedb/releases/tag/v1.51.1",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/40xxx/CVE-2026-40091.json",
        "https://github.com/authzed/spicedb/security/advisories/GHSA-jf4f-rr2c-9m58",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-40091"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-532"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/40xxx/CVE-2026-40091.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-40091",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 492437,
  "published_at": "2026-04-14T23:50:25.479+00:00"
}