Medium
Security advisory
Versions of the package blamer before 1.0.4 are vulnerable to Arbitrary Argument Injection via the blameByFile() API. The library does not sanitize for user input or validate the given file path conforms to a specific schema, nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-26143
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 20:08 UTC · Revision 1
Source evidence
Versions of the package blamer before 1.0.4 are vulnerable to Arbitrary Argument Injection via the blameByFile() API. The library does not sanitize for user input or validate the given file path conforms to a specific schema, nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options.
osv:CVE-2023-26143
Complete source record
{
"id": "ab778798cd3034b2feafdc7106af5933b317a2ea6edf4ff69217dfcb51bd63d9",
"url": "https://osv.dev/vulnerability/CVE-2023-26143",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2023-26143",
"summary": "Versions of the package blamer before 1.0.4 are vulnerable to Arbitrary Argument Injection via the blameByFile() API. The library does not sanitize for user input or validate the given file path conforms to a specific schema, nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options.",
"evidence": "osv:CVE-2023-26143",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-26143",
"aliases": [
"CVE-2023-26143",
"GHSA-6f9p-g466-f8v8"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L/E:P"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/kucherenko/blamer",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "2ca7c28bdd8d31bb7d8bd33e8a637c456476a853"
},
{
"fixed": "0965877f115753371a2570f10a63c455d2b2cde3"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:blamer_project:blamer:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.0.4"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "0965877f115753371a2570f10a63c455d2b2cde3"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v1.0.3",
"v1.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-26143.json"
}
}
],
"modified": "2026-10-28T02:30:39.058617917Z",
"provider": "osv",
"references": [
"https://gist.github.com/lirantal/14c3686370a86461f555d3f0703e02f9",
"https://security.snyk.io/vuln/SNYK-JS-BLAMER-5731318",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/26xxx/CVE-2023-26143.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-26143",
"https://github.com/kucherenko/blamer/commit/0965877f115753371a2570f10a63c455d2b2cde3"
],
"provider_metadata": {
"cwe_ids": [
"CWE-88"
],
"cna_assigner": "snyk",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/26xxx/CVE-2023-26143.json"
}
},
"related_cves": [
{
"value": "CVE-2023-26143",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 506513,
"published_at": "2023-09-19T05:00:01.083+00:00"
}