Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2019-5421

Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2019-5421
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:46 UTC · Revision 1

Source evidence

CVE-2019-5421

core-osv · Original source

Published 3 Apr 2019, 15:29 UTC

Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.

osv:CVE-2019-5421
Complete source record
{
  "id": "e91bfac69d9c0f95de02d606e30eee528301194ba1d1369619fcc369fa694ce8",
  "url": "https://osv.dev/vulnerability/CVE-2019-5421",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2019-5421",
    "summary": "Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.",
    "evidence": "osv:CVE-2019-5421",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2019-5421",
      "aliases": [
        "CVE-2019-5421",
        "GHSA-73rf-6mrf-759q"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/heartcombo/devise",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "3b0bc08ec67dd073ddd6d043c71646c2784ced6c"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:plataformatec:devise:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "4.5.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v4.5.0",
            "v4.4.3",
            "v4.4.2",
            "v4.4.1",
            "v4.4.0",
            "v4.3.0",
            "v4.2.1",
            "v4.2.0",
            "v4.1.0",
            "v4.0.1",
            "v4.0.0",
            "v4.0.0.rc2",
            "v4.0.0.rc1",
            "v3.5.3",
            "v3.5.2",
            "v3.5.1",
            "v3.5.0",
            "v3.4.1",
            "v3.4.0",
            "v3.3.0",
            "v3.2.4",
            "v3.2.3",
            "v3.2.2",
            "v3.2.1",
            "v3.2.0",
            "v3.1.0",
            "v3.1.0.rc2",
            "v3.1.0.rc",
            "v3.0.1",
            "v2.2.4",
            "v3.0.0",
            "v3.0.0.rc",
            "v2.2.3",
            "v2.1.2",
            "v2.2.2",
            "v2.2.1",
            "v2.2.0",
            "v2.2.0.rc",
            "v2.1.1",
            "v2.1.0",
            "v2.1.0.rc2",
            "v2.1.0.rc",
            "v2.0.3",
            "v2.0.2",
            "v2.0.1",
            "v2.0.0",
            "v2.0.0.rc2",
            "v2.0.0.rc",
            "v1.5.1",
            "v1.5.0",
            "v1.5.0.rc1",
            "v1.5.0.rc",
            "v1.4.7",
            "v1.4.6",
            "v1.4.4",
            "v1.4.3",
            "v1.4.2",
            "v1.4.1",
            "v1.4.0",
            "v1.3.1",
            "v1.3.0",
            "v1.2.0",
            "v1.2.rc2",
            "v1.2.rc",
            "v1.1.0",
            "v1.1.rc2",
            "v1.1.rc1",
            "v1.1.rc0",
            "v1.1.pre4",
            "v1.1.pre3",
            "v1.1.pre2",
            "v1.1.pre",
            "v1.0.1",
            "v1.0.0",
            "v0.9.1",
            "v0.9.0",
            "v0.8.2",
            "v0.8.1",
            "v0.8.0",
            "v0.7.5"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-5421.json"
          }
        }
      ],
      "modified": "2026-10-20T10:51:39.978691281Z",
      "provider": "osv",
      "references": [
        "https://github.com/plataformatec/devise/issues/4981",
        "https://github.com/plataformatec/devise/pull/4996"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2019-5421",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 382738,
  "published_at": "2019-04-03T15:29:01.663+00:00"
}