MCP Inspector is Vulnerable to Potential Command Execution via XSS When Connecting to an Untrusted MCP Server
The MCP inspector is a developer tool for testing and debugging MCP servers. A cross-site scripting issue was reported in versions of the MCP Inspector local development tool prior to 0.16.6 when connecting to untrusted remote MCP servers with a malicious redirect URI. This could be leveraged to interact directly with the inspector proxy to trigger arbitrary command execution. Users are advised to update to 0.16.6 to resolve this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-58444
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 8 Nov 2026, 01:10 UTC · Revision 1
Source evidence
MCP Inspector is Vulnerable to Potential Command Execution via XSS When Connecting to an Untrusted MCP Server
core-osv · Original sourcePublished 8 Sept 2025, 21:24 UTC
The MCP inspector is a developer tool for testing and debugging MCP servers. A cross-site scripting issue was reported in versions of the MCP Inspector local development tool prior to 0.16.6 when connecting to untrusted remote MCP servers with a malicious redirect URI. This could be leveraged to interact directly with the inspector proxy to trigger arbitrary command execution. Users are advised to update to 0.16.6 to resolve this issue.
osv:CVE-2025-58444
Complete source record
{
"id": "a61bbb9a2091cfa98700545999d398c75937177d21f876cbc3861d70d49a30c7",
"url": "https://osv.dev/vulnerability/CVE-2025-58444",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "MCP Inspector is Vulnerable to Potential Command Execution via XSS When Connecting to an Untrusted MCP Server",
"summary": "The MCP inspector is a developer tool for testing and debugging MCP servers. A cross-site scripting issue was reported in versions of the MCP Inspector local development tool prior to 0.16.6 when connecting to untrusted remote MCP servers with a malicious redirect URI. This could be leveraged to interact directly with the inspector proxy to trigger arbitrary command execution. Users are advised to update to 0.16.6 to resolve this issue.",
"evidence": "osv:CVE-2025-58444",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-58444",
"aliases": [
"CVE-2025-58444",
"GHSA-g9hg-qhmf-q45m"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/modelcontextprotocol/inspector",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "377211061b51315e0d1a5da585447290173de880"
},
{
"fixed": "650f3090d26344a672026b737d81586595bb1f60"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "0.16.6"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "650f3090d26344a672026b737d81586595bb1f60"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"0.16.5",
"0.16.4",
"0.16.3",
"0.16.2",
"0.16.0",
"0.16.1",
"0.15.0",
"0.14.3",
"0.14.2",
"0.14.1",
"0.14.0",
"0.13.0",
"0.12.0",
"0.11.0-amended",
"0.11.0",
"0.10.2",
"0.9.0",
"0.8.2",
"0.8.1-hotfix",
"0.8.1",
"0.8.0",
"0.7.0",
"0.6.0",
"0.5.1",
"0.4.1",
"0.4.0",
"0.3.0",
"0.2.7",
"0.2.6",
"0.2.5",
"0.2.4",
"0.2.3",
"0.2.2",
"0.2.1",
"0.2.0",
"0.1.0",
"0.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-58444.json"
}
}
],
"modified": "2026-10-28T02:30:52.318095483Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58444.json",
"https://github.com/modelcontextprotocol/inspector/security/advisories/GHSA-g9hg-qhmf-q45m",
"https://nvd.nist.gov/vuln/detail/CVE-2025-58444",
"https://github.com/modelcontextprotocol/inspector/commit/650f3090d26344a672026b737d81586595bb1f60"
],
"provider_metadata": {
"cwe_ids": [
"CWE-84"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58444.json"
}
},
"related_cves": [
{
"value": "CVE-2025-58444",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 521225,
"published_at": "2025-09-08T21:24:58.821+00:00"
}