MediumFix available
fence-agents — security advisory
In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.
- Products
- fence-agents
- Affected versions
- Not specified
- Fixed versions
- 4.0.17-1
- CVEs
- CVE-2014-0104
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:50 UTC · Revision 1
Source evidence
In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.
osv:DEBIAN-CVE-2014-0104
fence-agents
Fixed versions: 4.0.17-1
fence-agents
Fixed versions: 4.0.17-1
fence-agents
Fixed versions: 4.0.17-1
Complete source record
{
"id": "4b25049518d9de26003b380e9064e471b9d2f08dbf82fef1c8a7d9ebe872a2c7",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-0104",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-0104",
"summary": "In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.",
"evidence": "osv:DEBIAN-CVE-2014-0104",
"products": [
{
"name": {
"value": "fence-agents",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.0.17-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "fence-agents",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.0.17-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "fence-agents",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.0.17-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2014-0104",
"aliases": [
"DEBIAN-CVE-2014-0104"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.0.17-1"
}
]
}
],
"package": {
"name": "fence-agents",
"purl": "pkg:deb/debian/fence-agents?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0104.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.0.17-1"
}
]
}
],
"package": {
"name": "fence-agents",
"purl": "pkg:deb/debian/fence-agents?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0104.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.0.17-1"
}
]
}
],
"package": {
"name": "fence-agents",
"purl": "pkg:deb/debian/fence-agents?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0104.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-23T16:00:07.336708685Z",
"provider": "osv",
"upstream": [
"CVE-2014-0104"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-0104"
]
},
"related_cves": [
{
"value": "CVE-2014-0104",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 414635,
"published_at": "2020-01-02T17:15:11.08+00:00"
}