Skip to content
Heist/ feed
Back to feed
High

Apache Tomcat: Security constraint bypass for pre/post-resources

Type: advisorySources: OSV

Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Tomcat. When using PreResources or PostResources mounted other than at the root of the web application, it was possible to access those resources via an unexpected path. That path was likely not to be protected by the same security constraints as the expected path, allowing those security constraints to be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-49125
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 12:28 UTC · Revision 1

Source evidence

Apache Tomcat: Security constraint bypass for pre/post-resources

core-osv · Original source

Published 16 Jun 2025, 14:18 UTC

Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Tomcat. When using PreResources or PostResources mounted other than at the root of the web application, it was possible to access those resources via an unexpected path. That path was likely not to be protected by the same security constraints as the expected path, allowing those security constraints to be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

osv:CVE-2025-49125
Complete source record
{
  "id": "853b5d25bab9db3e0d68f3a9847f92bef8cf5527211fbd67a2d77cb619d93768",
  "url": "https://osv.dev/vulnerability/CVE-2025-49125",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Tomcat: Security constraint bypass for pre/post-resources",
    "summary": "Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Tomcat. When using PreResources or PostResources mounted other than at the root of the web application, it was possible to access those resources via an unexpected path. That path was likely not to be protected by the same security constraints as the expected path, allowing those security constraints to be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.",
    "evidence": "osv:CVE-2025-49125",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-49125",
      "aliases": [
        "BIT-tomcat-2025-49125",
        "CVE-2025-49125",
        "GHSA-wc4r-xq3c-5cf3"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/tomcat",
              "type": "GIT",
              "events": [
                {
                  "introduced": "16bf392c67833ad549733b58c350ff92b5ee782a"
                },
                {
                  "fixed": "05ccf0c3e22d388f0cf853e32485d8249d051f2f"
                },
                {
                  "introduced": "e9d17cddc285615807ec5fef09240777436b25dc"
                },
                {
                  "fixed": "0289da4f342744334e0fc5a53ee958e68024fead"
                },
                {
                  "introduced": "56e547d387ab49f688c93fe9ca082b1b5d94deed"
                },
                {
                  "fixed": "8a48dcb90f13f1670632e763e945f4cc9ef869e6"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "9.0.0"
                      },
                      {
                        "fixed": "9.0.106"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "10.1.0"
                      },
                      {
                        "fixed": "10.1.42"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "11.0.0"
                      },
                      {
                        "fixed": "11.0.8"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-49125.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:28.541796532Z",
      "provider": "osv",
      "references": [
        "https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/49xxx/CVE-2025-49125.json",
        "https://lists.apache.org/thread/m66cytbfrty9k7dc4cg6tl1czhsnbywk",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-49125"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-288"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "11.0.0-M1"
                  },
                  {
                    "last_affected": "11.0.7"
                  },
                  {
                    "introduced": "10.1.0-M1"
                  },
                  {
                    "last_affected": "10.1.41"
                  },
                  {
                    "introduced": "9.0.0.M1"
                  },
                  {
                    "last_affected": "9.0.105"
                  },
                  {
                    "introduced": "8.5.0"
                  },
                  {
                    "last_affected": "8.5.100"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/49xxx/CVE-2025-49125.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-49125",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 495393,
  "published_at": "2025-06-16T14:18:09.61+00:00"
}