sudo — security advisory
In Sudo before 1.9.12p2, the sudoedit (aka -e) feature mishandles extra arguments passed in the user-provided environment variables (SUDO_EDITOR, VISUAL, and EDITOR), allowing a local attacker to append arbitrary entries to the list of files to process. This can lead to privilege escalation. Affected versions are 1.8.0 through 1.9.12.p1. The problem exists because a user-specified editor may contain a "--" argument that defeats a protection mechanism, e.g., an EDITOR='vim -- /path/to/extra/file' value.
- Products
- sudo
- Affected versions
- Not specified
- Fixed versions
- 1.9.12p2-1
- CVEs
- CVE-2023-22809
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 15:45 UTC · Revision 1
Source evidence
In Sudo before 1.9.12p2, the sudoedit (aka -e) feature mishandles extra arguments passed in the user-provided environment variables (SUDO_EDITOR, VISUAL, and EDITOR), allowing a local attacker to append arbitrary entries to the list of files to process. This can lead to privilege escalation. Affected versions are 1.8.0 through 1.9.12.p1. The problem exists because a user-specified editor may contain a "--" argument that defeats a protection mechanism, e.g., an EDITOR='vim -- /path/to/extra/file' value.
osv:DEBIAN-CVE-2023-22809
sudo
Fixed versions: 1.9.12p2-1
sudo
Fixed versions: 1.9.12p2-1
sudo
Fixed versions: 1.9.12p2-1
Complete source record
{
"id": "771795d797e892528cdf4a2bc0b1773f4fb735efb381b966e25862b99c4607eb",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-22809",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-22809",
"summary": "In Sudo before 1.9.12p2, the sudoedit (aka -e) feature mishandles extra arguments passed in the user-provided environment variables (SUDO_EDITOR, VISUAL, and EDITOR), allowing a local attacker to append arbitrary entries to the list of files to process. This can lead to privilege escalation. Affected versions are 1.8.0 through 1.9.12.p1. The problem exists because a user-specified editor may contain a \"--\" argument that defeats a protection mechanism, e.g., an EDITOR='vim -- /path/to/extra/file' value.",
"evidence": "osv:DEBIAN-CVE-2023-22809",
"products": [
{
"name": {
"value": "sudo",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.12p2-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "sudo",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.12p2-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "sudo",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.12p2-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-22809",
"aliases": [
"DEBIAN-CVE-2023-22809"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.12p2-1"
}
]
}
],
"package": {
"name": "sudo",
"purl": "pkg:deb/debian/sudo?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-22809.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.12p2-1"
}
]
}
],
"package": {
"name": "sudo",
"purl": "pkg:deb/debian/sudo?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-22809.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.12p2-1"
}
]
}
],
"package": {
"name": "sudo",
"purl": "pkg:deb/debian/sudo?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-22809.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:01:36.111470070Z",
"provider": "osv",
"upstream": [
"CVE-2023-22809"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-22809"
]
},
"related_cves": [
{
"value": "CVE-2023-22809",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 455592,
"published_at": "2023-01-18T17:15:10.353+00:00"
}