Tag, Category, and Taxonomy Manager – AI Autotagger with OpenAI <= 3.40.1 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Taxonomy Term Manipulation
The Tag, Category, and Taxonomy Manager – AI Autotagger with OpenAI plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.40.1. This is due to the plugin not properly verifying that a user is authorized to perform an action in the "taxopress_merge_terms_batch" function. This makes it possible for authenticated attackers, with subscriber level access and above, to merge or delete arbitrary taxonomy terms.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-13354
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 01:48 UTC · Revision 1
Source evidence
Tag, Category, and Taxonomy Manager – AI Autotagger with OpenAI <= 3.40.1 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Taxonomy Term Manipulation
core-osv · Original sourcePublished 3 Dec 2025, 13:52 UTC
The Tag, Category, and Taxonomy Manager – AI Autotagger with OpenAI plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.40.1. This is due to the plugin not properly verifying that a user is authorized to perform an action in the "taxopress_merge_terms_batch" function. This makes it possible for authenticated attackers, with subscriber level access and above, to merge or delete arbitrary taxonomy terms.
osv:CVE-2025-13354
Complete source record
{
"id": "3b2f6040f542c93a1a0e19ccead7c3f379f34c8a07af31292f3e493a3cdc2aac",
"url": "https://osv.dev/vulnerability/CVE-2025-13354",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Tag, Category, and Taxonomy Manager – AI Autotagger with OpenAI <= 3.40.1 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Taxonomy Term Manipulation",
"summary": "The Tag, Category, and Taxonomy Manager – AI Autotagger with OpenAI plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.40.1. This is due to the plugin not properly verifying that a user is authorized to perform an action in the \"taxopress_merge_terms_batch\" function. This makes it possible for authenticated attackers, with subscriber level access and above, to merge or delete arbitrary taxonomy terms.",
"evidence": "osv:CVE-2025-13354",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-13354",
"aliases": [
"CVE-2025-13354"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/publishpress/publishpress-taxonomies",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "d2884994030f0e4329d3817301cd24b9983e58d1"
},
{
"fixed": "5eb2cee861ebd109152eea968aca0259c078c8b0"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:taxopress:taxopress:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.41.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "5eb2cee861ebd109152eea968aca0259c078c8b0"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v3.40.1",
"v3.40.0",
"v3.38.0",
"v3.37.4",
"v3.37.3",
"v3.37.2",
"v3.37.1",
"v3.37.0",
"v3.36.0",
"v3.35.1",
"v3.34.0",
"v3.33.0",
"v3.32.0",
"v3.31.0",
"v3.30.0",
"v3.28.1",
"v2.28.1",
"v3.28.0",
"v3.27.0",
"v3.26.0",
"v3.25.1",
"v3.25.0",
"v3.24.1",
"v3.24.0",
"v3.23.0",
"v3.22.0",
"v3.21.1",
"v3.21.0",
"v3.20.0",
"v3.13.0",
"v3.12.0",
"3.11.1",
"3.11.0",
"3.10.2",
"3.10.1",
"3.10.0",
"3.9.0",
"3.8.0",
"3.7.4",
"3.7.3",
"3.7.2",
"3.7.1",
"3.7.0",
"3.6.7",
"3.6.6",
"3.6.5",
"3.6.4",
"3.6.3",
"3.6.2",
"3.6.1",
"3.6.0",
"3.5.3",
"3.5.2",
"3.5.1",
"3.5.0",
"3.4.5",
"3.4.4",
"3.4.3",
"3.4.2",
"3.4.1",
"3.4.0",
"3.3.1",
"3.3.0",
"3.2.2",
"3.2.1",
"3.2.0",
"3.1.2",
"3.1.1",
"3.1.0",
"3.0.7.2",
"3.0.7.1",
"3.0.7",
"3.0.6.1",
"3.0.6",
"3.0.5.2",
"3.0.5.1",
"3.0.5",
"3.0.4.2",
"3.0.4.1",
"3.0.4",
"3.0.3",
"3.0.2",
"3.0.1",
"3.0.0",
"3.0",
"2.5.7",
"2.5.6",
"2.5.5",
"2.5.4",
"2.5.3",
"2.5.2",
"2.5.1",
"2.4.6",
"2.4.4",
"2.4.3"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-13354.json"
}
}
],
"modified": "2026-10-28T02:30:41.523303344Z",
"provider": "osv",
"references": [
"https://www.wordfence.com/threat-intel/vulnerabilities/id/05c1ee52-02c9-440b-9269-14ea8b73be45?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/13xxx/CVE-2025-13354.json",
"https://nvd.nist.gov/vuln/detail/CVE-2025-13354",
"https://github.com/TaxoPress/TaxoPress/commit/5eb2cee861ebd109152eea968aca0259c078c8b0"
],
"provider_metadata": {
"cwe_ids": [
"CWE-862"
],
"cna_assigner": "Wordfence",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/13xxx/CVE-2025-13354.json"
}
},
"related_cves": [
{
"value": "CVE-2025-13354",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 509213,
"published_at": "2025-12-03T13:52:43.424+00:00"
}