Unrated
Apache JSPWiki Cross-site scripting vulnerability on User Preferences screen
Type: advisorySources: OSV
A carefully crafted user preferences for submission could trigger an XSS vulnerability on Apache JSPWiki, related to the user preferences screen, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.2 or later.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-24948
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 02:49 UTC · Revision 1
Source evidence
Apache JSPWiki Cross-site scripting vulnerability on User Preferences screen
core-osv · Original sourcePublished 25 Feb 2022, 08:30 UTC
A carefully crafted user preferences for submission could trigger an XSS vulnerability on Apache JSPWiki, related to the user preferences screen, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.2 or later.
osv:CVE-2022-24948
Complete source record
{
"id": "1133fe9bebf2d108cdb2b098e8c12d1ab745c58b639a306ea13f6c370062b146",
"url": "https://osv.dev/vulnerability/CVE-2022-24948",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache JSPWiki Cross-site scripting vulnerability on User Preferences screen",
"summary": "A carefully crafted user preferences for submission could trigger an XSS vulnerability on Apache JSPWiki, related to the user preferences screen, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.2 or later.",
"evidence": "osv:CVE-2022-24948",
"products": [],
"severity": "unknown",
"structured": {
"id": "CVE-2022-24948",
"aliases": [
"CVE-2022-24948",
"GHSA-9953-fmrw-v4vm"
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/jspwiki",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "c85363be9980acc7625dac1fd05e907ebc3e34c2"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.11.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.11.1-RC1",
"2.11.1",
"2.11.0-RC2",
"2.11.0",
"2.11.0-RC1",
"2.11.0.M8-RC1",
"2.11.0.M8",
"2.11.0.M7-RC1",
"2.11.0.M7",
"2.11.0.M6-RC1",
"2.11.0.M6",
"2.11.0.M5-RC3",
"2.11.0.M5",
"2.11.0.M5-RC2",
"2.11.0.M5-RC1",
"2.11.0.M4-RC2",
"2.11.0.M4",
"2.11.0.M4-RC1",
"2.11.0.M3-RC2",
"2.11.0.M3",
"2.11.0.M3-RC1",
"2.11.0.M2-RC1",
"2.11.0.M2",
"2.11.0.M1.RC3",
"2.11.0.M1",
"2.11.0.M1-RC2",
"2.11.0.M1-RC1",
"2.10.5-RC2",
"2.10.5",
"2.10.5-RC1",
"2.10.4-RC3",
"2.10.4",
"2.10.4-RC2",
"2.10.4-RC1",
"2.10.3-RC2",
"2.10.3",
"2.10.3-RC1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-24948.json"
}
}
],
"modified": "2026-10-28T02:30:25.155468452Z",
"provider": "osv",
"references": [
"https://lists.apache.org/thread/86p0yzopc4mw2h5bkwpt927b2c8tfq3b",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24948.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-24948"
],
"provider_metadata": {
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "2.11.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "VersionTextExtraction"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24948.json"
}
},
"related_cves": [
{
"value": "CVE-2022-24948",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 492038,
"published_at": "2022-02-25T08:30:19+00:00"
}