libspring-java — security advisory
Pivotal Spring Framework through 5.3.16 suffers from a potential remote code execution (RCE) issue if used for Java deserialization of untrusted data. Depending on how the library is implemented within a product, this issue may or not occur, and authentication may be required. NOTE: the vendor's position is that untrusted data is not an intended use case. The product's behavior will not be changed because some users rely on deserialization of trusted data.
- Products
- libspring-java
- Affected versions
- Not specified
- Fixed versions
- 4.2.7-1
- CVEs
- CVE-2016-1000027
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 09:02 UTC · Revision 1
Source evidence
Pivotal Spring Framework through 5.3.16 suffers from a potential remote code execution (RCE) issue if used for Java deserialization of untrusted data. Depending on how the library is implemented within a product, this issue may or not occur, and authentication may be required. NOTE: the vendor's position is that untrusted data is not an intended use case. The product's behavior will not be changed because some users rely on deserialization of trusted data.
osv:DEBIAN-CVE-2016-1000027
libspring-java
Fixed versions: 4.2.7-1
libspring-java
Fixed versions: 4.2.7-1
libspring-java
Fixed versions: 4.2.7-1
Complete source record
{
"id": "62bfdccf01e4cc434de1dd83c9c613f0380ccd906c4e00868fd691b27115a43b",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2016-1000027",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2016-1000027",
"summary": "Pivotal Spring Framework through 5.3.16 suffers from a potential remote code execution (RCE) issue if used for Java deserialization of untrusted data. Depending on how the library is implemented within a product, this issue may or not occur, and authentication may be required. NOTE: the vendor's position is that untrusted data is not an intended use case. The product's behavior will not be changed because some users rely on deserialization of trusted data.",
"evidence": "osv:DEBIAN-CVE-2016-1000027",
"products": [
{
"name": {
"value": "libspring-java",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.2.7-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libspring-java",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.2.7-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libspring-java",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.2.7-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2016-1000027",
"aliases": [
"DEBIAN-CVE-2016-1000027"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.2.7-1"
}
]
}
],
"package": {
"name": "libspring-java",
"purl": "pkg:deb/debian/libspring-java?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2016-1000027.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.2.7-1"
}
]
}
],
"package": {
"name": "libspring-java",
"purl": "pkg:deb/debian/libspring-java?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2016-1000027.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.2.7-1"
}
]
}
],
"package": {
"name": "libspring-java",
"purl": "pkg:deb/debian/libspring-java?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2016-1000027.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
}
],
"modified": "2026-10-08T09:47:36.139556967Z",
"provider": "osv",
"upstream": [
"CVE-2016-1000027"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2016-1000027"
]
},
"related_cves": [
{
"value": "CVE-2016-1000027",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 98908,
"published_at": "2020-01-02T23:15:11.857+00:00"
}