HighFix available
vim — security advisory
Integer Overflow or Wraparound in GitHub repository vim/vim prior to 9.0.1532.
- Products
- vim
- Affected versions
- 2:9.0.1378-2
- Fixed versions
- 2:9.0.1378-2+deb12u1, 2:9.0.1658-1
- CVEs
- CVE-2023-2610
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 15:51 UTC · Revision 1
Source evidence
Integer Overflow or Wraparound in GitHub repository vim/vim prior to 9.0.1532.
osv:DEBIAN-CVE-2023-2610
vim
Fixed versions: 2:9.0.1378-2+deb12u1
vim
Fixed versions: 2:9.0.1658-1
vim
Fixed versions: 2:9.0.1658-1
Complete source record
{
"id": "ffec0503b9b401568d3055a45cdb3147a1f1d55ecb279b55061b4237b39d72fa",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-2610",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-2610",
"summary": "Integer Overflow or Wraparound in GitHub repository vim/vim prior to 9.0.1532.",
"evidence": "osv:DEBIAN-CVE-2023-2610",
"products": [
{
"name": {
"value": "vim",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2:9.0.1378-2+deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "2:9.0.1378-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "vim",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2:9.0.1658-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "vim",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2:9.0.1658-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-2610",
"aliases": [
"DEBIAN-CVE-2023-2610"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2:9.0.1378-2+deb12u1"
}
]
}
],
"package": {
"name": "vim",
"purl": "pkg:deb/debian/vim?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2:9.0.1378-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-2610.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2:9.0.1658-1"
}
]
}
],
"package": {
"name": "vim",
"purl": "pkg:deb/debian/vim?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-2610.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2:9.0.1658-1"
}
]
}
],
"package": {
"name": "vim",
"purl": "pkg:deb/debian/vim?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-2610.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:11.035626166Z",
"provider": "osv",
"upstream": [
"CVE-2023-2610"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-2610"
]
},
"related_cves": [
{
"value": "CVE-2023-2610",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 455881,
"published_at": "2023-05-09T22:15:10.197+00:00"
}