Apache APISIX: unauthenticated impersonation issue in saml-auth
Improper verification of cryptographic signature vulnerability in Apache APISIX. Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
- Products
- apisix
- Affected versions
- Not specified
- Fixed versions
- 3.19.0
- CVEs
- CVE-2026-94212
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 12:31 UTC · Revision 1
Source evidence
Apache APISIX: unauthenticated impersonation issue in saml-auth
core-osv · Original sourcePublished 9 Oct 2026, 10:43 UTC
Improper verification of cryptographic signature vulnerability in Apache APISIX. Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
osv:BIT-apisix-2026-94212
apisix
Fixed versions: 3.19.0
Complete source record
{
"id": "2c759f37b628d33878b79a0f1ada3c283eea9204b77d2f0071eaa4f403498a93",
"url": "https://osv.dev/vulnerability/BIT-apisix-2026-94212",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache APISIX: unauthenticated impersonation issue in saml-auth",
"summary": "Improper verification of cryptographic signature vulnerability in Apache APISIX. Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.",
"evidence": "osv:BIT-apisix-2026-94212",
"products": [
{
"name": {
"value": "apisix",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.19.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "BIT-apisix-2026-94212",
"aliases": [
"BIT-apisix-2026-94212",
"CVE-2026-94212"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "3.17.0"
},
{
"fixed": "3.19.0"
}
]
}
],
"package": {
"name": "apisix",
"purl": "pkg:bitnami/apisix",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/apisix/BIT-apisix-2026-94212.json"
}
}
],
"modified": "2026-10-09T12:00:03.566955986Z",
"provider": "osv",
"references": [
"https://lists.apache.org/thread.html/1230fnojnmc7bfz3n0nkt7tkcld9d1sc",
"https://nvd.nist.gov/vuln/detail/CVE-2026-94212"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*"
],
"severity": "Medium"
}
},
"related_cves": [
{
"value": "CVE-2026-94212",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 120644,
"published_at": "2026-10-09T10:43:47.772+00:00"
}