Security advisory
In all versions of Node.js prior to 6.14.4, 8.11.4 and 10.9.0 when used with UCS-2 encoding (recognized by Node.js under the names `'ucs2'`, `'ucs-2'`, `'utf16le'` and `'utf-16le'`), `Buffer#write()` can be abused to write outside of the bounds of a single `Buffer`. Writes that start from the second-to-last position of a buffer cause a miscalculation of the maximum length of the input bytes to be written.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-12115
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:35 UTC · Revision 1
Source evidence
In all versions of Node.js prior to 6.14.4, 8.11.4 and 10.9.0 when used with UCS-2 encoding (recognized by Node.js under the names `'ucs2'`, `'ucs-2'`, `'utf16le'` and `'utf-16le'`), `Buffer#write()` can be abused to write outside of the bounds of a single `Buffer`. Writes that start from the second-to-last position of a buffer cause a miscalculation of the maximum length of the input bytes to be written.
osv:CVE-2018-12115
Complete source record
{
"id": "f1389fbdce00f8a441e51dd8da336ce439b4de9a360c2bfe517fd4a031e68efd",
"url": "https://osv.dev/vulnerability/CVE-2018-12115",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-12115",
"summary": "In all versions of Node.js prior to 6.14.4, 8.11.4 and 10.9.0 when used with UCS-2 encoding (recognized by Node.js under the names `'ucs2'`, `'ucs-2'`, `'utf16le'` and `'utf-16le'`), `Buffer#write()` can be abused to write outside of the bounds of a single `Buffer`. Writes that start from the second-to-last position of a buffer cause a miscalculation of the maximum length of the input bytes to be written.",
"evidence": "osv:CVE-2018-12115",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2018-12115",
"aliases": [
"CVE-2018-12115"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/nodejs/node",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "1cb5aed5f596a9cb5b68e3a676222c0c35501a5e"
},
{
"introduced": "0d8021e5a4cf0a6aa3a700a361f6d42c2894f2ba"
},
{
"fixed": "0cae3c3fe5e3f4c275701446a4baf1f2727344f6"
},
{
"introduced": "cf41627411886000429bde058a6594fb7f6d6d47"
},
{
"fixed": "03b825811ed4af0addcdf6e75bacb3dc1c4c5940"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "6.14.4"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.11.4"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "10.0.0"
},
{
"fixed": "10.9.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v10.8.0",
"v10.7.0",
"v10.6.0",
"v10.5.0",
"v10.4.1",
"v8.11.3",
"v6.14.3",
"v10.4.0",
"v10.3.0",
"v10.2.1",
"v10.2.0",
"v8.11.2",
"v10.1.0",
"v6.14.2",
"v10.0.0",
"v8.11.1",
"v6.14.1",
"v6.14.0",
"v8.11.0",
"v8.10.0",
"v6.13.1",
"v6.13.0",
"v8.9.4",
"v6.12.3",
"v8.9.3",
"v6.12.2",
"v8.9.2",
"v6.12.1",
"v8.9.1",
"v6.12.0",
"v8.9.0",
"v8.8.1",
"v6.11.5",
"v8.8.0",
"v8.7.0",
"v6.11.4",
"v8.6.0",
"v8.5.0",
"v6.11.3",
"v8.4.0",
"v8.3.0",
"v6.11.2",
"v8.2.1",
"v8.2.0",
"v8.1.4",
"v6.11.1",
"v8.1.3",
"v8.1.2",
"v8.1.1",
"v8.1.0",
"v6.11.0",
"v8.0.0",
"v6.10.3",
"v6.10.2",
"v6.10.1",
"v6.10.0",
"v6.9.5",
"v6.9.4",
"v6.9.3",
"v6.9.2",
"v6.9.1",
"v6.9.0",
"v6.8.1",
"v6.8.0",
"v6.7.0",
"v6.6.0",
"v6.5.0",
"v6.4.0",
"v6.3.1",
"v6.3.0",
"v6.2.2",
"v6.2.1",
"v6.2.0",
"v6.1.0",
"v6.0.0",
"v3.0.0",
"v2.5.0",
"v2.4.0",
"v2.3.4",
"v2.3.3",
"v2.3.2",
"v2.3.1",
"v2.3.0",
"v2.2.1",
"v2.2.0",
"v2.1.0",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"v1.7.1",
"v1.7.0",
"v1.6.4",
"v1.6.3",
"v1.6.2",
"v1.6.1",
"v1.6.0",
"v1.5.1",
"v1.5.0",
"v1.4.3",
"v1.4.2",
"v1.4.1",
"v1.3.0",
"v1.2.0",
"v1.1.0",
"v1.0.4",
"v1.0.3",
"v1.0.2-release",
"v1.0.2",
"v1.0.1-release",
"v1.0.1",
"v0.7.3",
"v0.7.2",
"v0.7.0",
"v0.6.1",
"v0.6.0",
"v0.5.10",
"v0.5.9",
"v0.5.8",
"v0.5.7",
"v0.5.6",
"v0.5.5-rc1",
"v0.5.5",
"v0.5.4",
"v0.5.3",
"v0.5.2",
"v0.5.1",
"v0.5.0",
"v0.4.0",
"v0.3.8",
"v0.3.7",
"v0.3.6",
"v0.3.5",
"v0.3.4",
"v0.3.2",
"v0.3.1",
"v0.3.0",
"v0.2.0",
"v0.1.104",
"v0.1.103",
"v0.1.102",
"v0.1.101",
"v0.1.100",
"v0.1.99",
"v0.1.98",
"v0.1.97",
"v0.1.96",
"v0.1.95",
"v0.1.94",
"v0.1.93",
"v0.1.92",
"v0.1.33",
"v0.1.32",
"v0.1.31",
"v0.1.30",
"v0.1.29",
"v0.1.28",
"v0.1.27",
"v0.1.26",
"v0.1.25",
"v0.1.24",
"v0.1.23",
"v0.1.22",
"v0.1.21",
"v0.1.20",
"v0.1.19",
"v0.1.18",
"v0.1.17",
"v0.1.16",
"v0.1.15",
"v0.1.14",
"v0.1.13",
"v0.1.12",
"v0.1.11",
"v0.1.10",
"v0.1.9",
"v0.1.8",
"v0.1.7",
"v0.1.6",
"v0.1.5",
"v0.1.4",
"v0.1.3",
"v0.1.2",
"v0.1.1",
"v0.1.0",
"v0.0.6",
"v0.0.4",
"v0.0.3",
"v0.0.2",
"v0.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-12115.json"
}
}
],
"modified": "2026-10-24T10:30:20.606978267Z",
"provider": "osv",
"references": [
"https://access.redhat.com/errata/RHSA-2018:2552",
"https://access.redhat.com/errata/RHSA-2018:2553",
"https://access.redhat.com/errata/RHSA-2018:2944",
"https://access.redhat.com/errata/RHSA-2018:2949",
"https://access.redhat.com/errata/RHSA-2018:3537",
"https://nodejs.org/en/blog/vulnerability/august-2018-security-releases/",
"https://security.gentoo.org/glsa/202003-48"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:*"
],
"vendor_product": "redhat:openshift_container_platform",
"extracted_events": [
{
"range": [
{
"introduced": "3.11"
},
{
"last_affected": "3.11"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2018-12115",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 430298,
"published_at": "2018-08-21T12:29:00.21+00:00"
}