High
Security advisory
Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function. **Note:** In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-21129
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 19:15 UTC · Revision 1
Source evidence
Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function. **Note:** In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.
osv:CVE-2022-21129
Complete source record
{
"id": "3c96634142d4fa5baf3ac9e5402e6f513435ecb193f4cbb600b1c07b86ec5287",
"url": "https://osv.dev/vulnerability/CVE-2022-21129",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2022-21129",
"summary": "Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function. **Note:** In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.",
"evidence": "osv:CVE-2022-21129",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-21129",
"aliases": [
"CVE-2022-21129",
"GHSA-c6rx-gxqv-vr5j"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/paypal/nemo-appium",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "aa271d36dd5c81baae3c43aa2616c84f0ee4195f"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"fixed": "aa271d36dd5c81baae3c43aa2616c84f0ee4195f"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v0.0.8",
"v0.0.7",
"v0.0.6"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-21129.json"
}
}
],
"modified": "2026-10-28T02:30:22.983057128Z",
"provider": "osv",
"references": [
"https://github.com/paypal/nemo-appium/blob/master/index.js%23L27",
"https://security.snyk.io/vuln/SNYK-JS-NEMOAPPIUM-3183747",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/21xxx/CVE-2022-21129.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-21129",
"https://github.com/paypal/nemo-appium/commit/aa271d36dd5c81baae3c43aa2616c84f0ee4195f"
],
"provider_metadata": {
"cwe_ids": [
"CWE-78"
],
"cna_assigner": "snyk",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "0.0.9"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
},
{
"extracted_events": [
{
"range": [
{
"fixed": "0.0.9"
}
],
"source": "DESCRIPTION"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/21xxx/CVE-2022-21129.json"
}
},
"related_cves": [
{
"value": "CVE-2022-21129",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 489033,
"published_at": "2023-01-31T05:00:01.701+00:00"
}