Reflected Cross-Site Scripting (XSS) Vulnerability in LinkAce
LinkAce is a self-hosted archive to collect links of your favorite websites. Prior to 1.15.6, a reflected cross-site scripting (XSS) vulnerability exists in the LinkAce. This issue occurs in the "URL" field of the "Edit Link" module, where user input is not properly sanitized or encoded before being reflected in the HTML response. This allows attackers to inject and execute arbitrary JavaScript in the context of the victim’s browser, leading to potential session hijacking, data theft, and unauthorized actions. This vulnerability is fixed in 1.15.6.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-56507
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 12:01 UTC · Revision 1
Source evidence
Reflected Cross-Site Scripting (XSS) Vulnerability in LinkAce
core-osv · Original sourcePublished 27 Dec 2024, 15:50 UTC
LinkAce is a self-hosted archive to collect links of your favorite websites. Prior to 1.15.6, a reflected cross-site scripting (XSS) vulnerability exists in the LinkAce. This issue occurs in the "URL" field of the "Edit Link" module, where user input is not properly sanitized or encoded before being reflected in the HTML response. This allows attackers to inject and execute arbitrary JavaScript in the context of the victim’s browser, leading to potential session hijacking, data theft, and unauthorized actions. This vulnerability is fixed in 1.15.6.
osv:CVE-2024-56507
Complete source record
{
"id": "4cc173c9daec91214d4caa5cc7e1589fefafd48323ff6b7ec72fc1ee7fc2cee2",
"url": "https://osv.dev/vulnerability/CVE-2024-56507",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Reflected Cross-Site Scripting (XSS) Vulnerability in LinkAce",
"summary": "LinkAce is a self-hosted archive to collect links of your favorite websites. Prior to 1.15.6, a reflected cross-site scripting (XSS) vulnerability exists in the LinkAce. This issue occurs in the \"URL\" field of the \"Edit Link\" module, where user input is not properly sanitized or encoded before being reflected in the HTML response. This allows attackers to inject and execute arbitrary JavaScript in the context of the victim’s browser, leading to potential session hijacking, data theft, and unauthorized actions. This vulnerability is fixed in 1.15.6.",
"evidence": "osv:CVE-2024-56507",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-56507",
"aliases": [
"CVE-2024-56507",
"GHSA-cjcg-wj4p-pgc5"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/kovah/linkace",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "536632067f338f18a56941dc1483e09004f2730d"
},
{
"fixed": "c7cd6a323a03ccd89c7f905f7d9f2afc265b7b67"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:linkace:linkace:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.15.6"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "c7cd6a323a03ccd89c7f905f7d9f2afc265b7b67"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v1.15.5",
"v1.15.4",
"v1.15.3",
"v1.15.2",
"v1.15.1",
"v1.15.0",
"v1.14.2",
"v1.14.1",
"v1.14.0",
"v1.13.0",
"v1.12.2",
"v1.12.1",
"v1.12.0",
"v1.11.4",
"v1.11.3",
"v1.11.2",
"v1.11.1",
"v1.11.0",
"v1.10.5",
"v1.10.4",
"v1.10.3",
"v1.10.2",
"v1.10.1",
"v1.10.0",
"v1.9.2",
"v1.9.1",
"v1.9.0",
"v1.8.1",
"v1.8.0",
"v1.7.0",
"v1.6.4",
"v1.6.3",
"v1.6.2",
"v1.6.1",
"v1.6.0",
"v1.5.0",
"v1.4.1",
"v1.4.0",
"v1.3.1",
"v1.3.0",
"v1.2.2",
"v1.2.1",
"v1.2.0",
"v1.1.0",
"v1.0.1",
"v1.0.0",
"v0.0.44",
"v0.0.43",
"v0.0.42",
"v0.0.41",
"v0.0.40",
"v0.0.39",
"v0.0.38",
"v0.0.37",
"v0.0.36",
"v0.0.35",
"v0.0.34",
"v0.0.33",
"v0.0.32",
"v0.0.31",
"v0.0.30",
"v0.0.29",
"v0.0.28",
"v0.0.27",
"v0.0.26",
"v0.0.25",
"v0.0.24",
"v0.0.23",
"v0.0.22",
"v0.0.21",
"v0.0.20",
"v0.0.19",
"v0.0.18",
"v0.0.17",
"v0.0.16",
"v0.0.15",
"v0.0.14",
"v0.0.13",
"v0.0.12",
"v0.0.11",
"v0.0.10",
"v0.0.9",
"v0.0.8",
"v0.0.7",
"v0.0.6",
"v0.0.5",
"v0.0.4",
"v0.0.3",
"v0.0.2",
"v0.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-56507.json"
}
}
],
"modified": "2026-10-28T02:30:35.316251894Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/56xxx/CVE-2024-56507.json",
"https://github.com/Kovah/LinkAce/security/advisories/GHSA-cjcg-wj4p-pgc5",
"https://nvd.nist.gov/vuln/detail/CVE-2024-56507",
"https://github.com/Kovah/LinkAce/commit/c7cd6a323a03ccd89c7f905f7d9f2afc265b7b67"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/56xxx/CVE-2024-56507.json"
}
},
"related_cves": [
{
"value": "CVE-2024-56507",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 502259,
"published_at": "2024-12-27T15:50:09.784+00:00"
}