Skip to content
Heist/ feed
Back to feed
CriticalFix available

Drupal core - Critical - Cross-site scripting - SA-CORE-2026-001

Type: patchSources: Drupal security

Drupal core’s jQuery integration for AJAX modal dialog boxes insufficiently sanitizes certain options, creating a cross-site scripting vulnerability. Update supported Drupal branches to the listed fixed versions.

Products
Drupal core
Affected versions
>= 8.0.0 < 10.5.9 || >= 10.6.0 < 10.6.7 || >= 11.0.0 < 11.2.11 || >= 11.3.0 < 11.3.7
Fixed versions
Drupal 10.5.9, Drupal 10.6.7, Drupal 11.2.11, Drupal 11.3.7
CVEs
CVE-2026-6365
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 12:39 UTC · Revision 1

Source evidence

Drupal core - Critical - Cross-site scripting - SA-CORE-2026-001

official-drupal-security · Original source

Published 15 Apr 2026, 19:24 UTC

Drupal core’s jQuery integration for AJAX modal dialog boxes insufficiently sanitizes certain options, creating a cross-site scripting vulnerability. Update supported Drupal branches to the listed fixed versions.

Drupal core's jQuery integration for AJAX modal dialog boxes does not sufficiently sanitize certain options, which can lead to a cross-site scripting (XSS) vulnerability.

Drupal core

Fixed versions: Drupal 10.5.9, Drupal 10.6.7, Drupal 11.2.11, Drupal 11.3.7

Complete source record
{
  "id": "d308b55ce070f5c4cc2ac358b0d3b3619b7a549f4d836db7ea3a86d5e3c7842d",
  "url": "https://www.drupal.org/sa-core-2026-001",
  "method": "llm",
  "payload": {
    "kind": "patch",
    "title": "Drupal core - Critical - Cross-site scripting - SA-CORE-2026-001",
    "summary": "Drupal core’s jQuery integration for AJAX modal dialog boxes insufficiently sanitizes certain options, creating a cross-site scripting vulnerability. Update supported Drupal branches to the listed fixed versions.",
    "evidence": "Drupal core's jQuery integration for AJAX modal dialog boxes does not sufficiently sanitize certain options, which can lead to a cross-site scripting (XSS) vulnerability.",
    "products": [
      {
        "name": {
          "value": "Drupal core",
          "evidence": "Project: Drupal core"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "Drupal 10.5.9",
            "evidence": "If you use Drupal 10.5.x, update to Drupal 10.5.9."
          },
          {
            "value": "Drupal 10.6.7",
            "evidence": "If you use Drupal 10.6.x, update to Drupal 10.6.7."
          },
          {
            "value": "Drupal 11.2.11",
            "evidence": "If you use Drupal 11.2.x, update to Drupal 11.2.11."
          },
          {
            "value": "Drupal 11.3.7",
            "evidence": "If you use Drupal 11.3.x, update to Drupal 11.3.7."
          }
        ],
        "affected_versions": [
          {
            "value": ">= 8.0.0 < 10.5.9 || >= 10.6.0 < 10.6.7 || >= 11.0.0 < 11.2.11 || >= 11.3.0 < 11.3.7",
            "evidence": "Affected versions: >= 8.0.0 < 10.5.9 || >= 10.6.0 < 10.6.7 || >= 11.0.0 < 11.2.11 || >= 11.3.0 < 11.3.7"
          }
        ]
      }
    ],
    "severity": "critical",
    "fixed_cves": [],
    "related_cves": [
      {
        "value": "CVE-2026-6365",
        "evidence": "CVE IDs: CVE-2026-6365"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "Security risk: Critical"
  },
  "source_id": "official-drupal-security",
  "document_id": 23468,
  "published_at": "2026-04-15T19:24:30+00:00"
}