Security advisory
phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-4043
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:29 UTC · Revision 1
Source evidence
phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.
osv:CVE-2020-4043
Complete source record
{
"id": "0a42e0e10cf346cc5f02014df5b7b2e5bf376b2c1edb10d50ff8d5672e7b5c00",
"url": "https://osv.dev/vulnerability/CVE-2020-4043",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-4043",
"summary": "phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.",
"evidence": "osv:CVE-2020-4043",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2020-4043",
"aliases": [
"CVE-2020-4043",
"GHSA-qr95-4mq5-r3fh"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/phpmussel/phpmussel",
"type": "GIT",
"events": [
{
"introduced": "f9fff7a116868cbc57c74f25c4f01df0f5dc0686"
},
{
"fixed": "0e90c10d24239495f5338fa90779e25dcfc15a5b"
},
{
"fixed": "97f25973433921c1f953430f32d3081adc4851a4"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:phpmussel_project:phpmussel:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.0.0"
},
{
"fixed": "1.6.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "97f25973433921c1f953430f32d3081adc4851a4"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v1.5.0",
"v1.4.0",
"v1.3.1",
"v1.3.0",
"v1.2.0",
"v1.1.0",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-4043.json"
}
}
],
"modified": "2026-10-20T10:54:22.181617512Z",
"provider": "osv",
"references": [
"https://github.com/phpMussel/phpMussel/security/advisories/GHSA-qr95-4mq5-r3fh",
"https://github.com/phpMussel/phpMussel/security/policy#currently-known-vulnerabilities",
"https://github.com/phpMussel/phpMussel/commit/97f25973433921c1f953430f32d3081adc4851a4",
"https://github.com/phpMussel/phpMussel/issues/167",
"https://github.com/phpMussel/phpMussel/pull/173"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2020-4043",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385208,
"published_at": "2020-06-10T20:15:14.483+00:00"
}