Skip to content
Heist/ feed
Back to feed
CriticalFix available

php8.2 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-31631

In PHP versions 8.0.* before 8.0.27, 8.1.* before 8.1.15, 8.2.* before 8.2.2 when using PDO::quote() function to quote user-supplied data for SQLite, supplying an overly long string may cause the driver to incorrectly quote the data, which may further lead to SQL injection vulnerabilities.

Products
php8.2
Affected versions
Not specified
Fixed versions
8.2.1-1
CVEs
CVE-2022-31631
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:50 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-31631

core-osv · Original source

Published 12 Feb 2025, 22:15 UTC

In PHP versions 8.0.* before 8.0.27, 8.1.* before 8.1.15, 8.2.* before 8.2.2 when using PDO::quote() function to quote user-supplied data for SQLite, supplying an overly long string may cause the driver to incorrectly quote the data, which may further lead to SQL injection vulnerabilities.

osv:DEBIAN-CVE-2022-31631

php8.2

Fixed versions: 8.2.1-1

Complete source record
{
  "id": "b01c7c0318b8ea1d40bf56b3c3ca69b9acc24ee743e7f3b0c7a6d280ae229799",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-31631",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-31631",
    "summary": "In PHP versions 8.0.* before 8.0.27, 8.1.* before 8.1.15, 8.2.* before 8.2.2 when using PDO::quote() function to quote user-supplied data for SQLite, supplying an overly long string may cause the driver to incorrectly quote the data, which may further lead to SQL injection vulnerabilities.",
    "evidence": "osv:DEBIAN-CVE-2022-31631",
    "products": [
      {
        "name": {
          "value": "php8.2",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "8.2.1-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "DEBIAN-CVE-2022-31631",
      "aliases": [
        "DEBIAN-CVE-2022-31631"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "8.2.1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "php8.2",
            "purl": "pkg:deb/debian/php8.2?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-31631.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:02:30.627105375Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-31631"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-31631"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-31631",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 323503,
  "published_at": "2025-02-12T22:15:29.007+00:00"
}