Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2019-17673

WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2019-17673
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 08:52 UTC · Revision 1

Source evidence

CVE-2019-17673

core-osv · Original source

Published 17 Oct 2019, 13:15 UTC

WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.

osv:CVE-2019-17673
Complete source record
{
  "id": "db849974ee99a00421bbdeaa750e295bbfc419c5168c7805574c18ecadfbaec7",
  "url": "https://osv.dev/vulnerability/CVE-2019-17673",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2019-17673",
    "summary": "WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.",
    "evidence": "osv:CVE-2019-17673",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2019-17673",
      "aliases": [
        "CVE-2019-17673"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wordpress/wordpress",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "9b84a21d66d7da3edec388f49234c1c41daed9ad"
                },
                {
                  "fixed": "b224c251adfa16a5f84074a3c0886270c9df38de"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.2.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "b224c251adfa16a5f84074a3c0886270c9df38de"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-17673.json"
          }
        },
        {
          "ranges": [
            {
              "repo": "https://github.com/wordpress/wordpress-develop",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "c5f94fc512bdea317e3e433b22a2f11ef959e515"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.2.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-17673.json"
          }
        }
      ],
      "modified": "2026-10-24T10:50:35.225275652Z",
      "provider": "osv",
      "references": [
        "https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html",
        "https://seclists.org/bugtraq/2020/Jan/8",
        "https://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/",
        "https://wpvulndb.com/vulnerabilities/9911",
        "https://www.debian.org/security/2020/dsa-4599",
        "https://www.debian.org/security/2020/dsa-4677",
        "https://core.trac.wordpress.org/changeset/46478",
        "https://github.com/WordPress/WordPress/commit/b224c251adfa16a5f84074a3c0886270c9df38de"
      ],
      "provider_metadata": {
        "unresolved_ranges": [
          {
            "cpes": [
              "cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*",
              "cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
            ],
            "vendor_product": "debian:debian_linux",
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "9.0"
                  },
                  {
                    "last_affected": "9.0"
                  },
                  {
                    "introduced": "10.0"
                  },
                  {
                    "last_affected": "10.0"
                  }
                ],
                "source": "CPE_STRING"
              }
            ]
          }
        ]
      }
    },
    "related_cves": [
      {
        "value": "CVE-2019-17673",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 442321,
  "published_at": "2019-10-17T13:15:11.077+00:00"
}