Security advisory
Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-6928
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:22 UTC · Revision 1
Source evidence
Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.
osv:CVE-2017-6928
Complete source record
{
"id": "d6a3ef9a3633b3c64b76ced75d075d91c78c636b81d08589a0656d803e6449c6",
"url": "https://osv.dev/vulnerability/CVE-2017-6928",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-6928",
"summary": "Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.",
"evidence": "osv:CVE-2017-6928",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2017-6928",
"aliases": [
"CVE-2017-6928",
"GHSA-66mv-q8r2-hj8w"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/drupal/drupal",
"type": "GIT",
"events": [
{
"introduced": "497914920385b7016ac9c9367e0198530787adf2"
},
{
"fixed": "bc929eb17c4f4eea83cb796b7c5bbb984bf288bd"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "7.0"
},
{
"fixed": "7.57"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"7.56",
"7.55",
"7.54",
"7.51",
"7.50",
"7.43",
"7.42",
"7.40",
"7.37",
"7.36",
"7.33",
"7.30",
"7.28",
"7.25",
"7.23",
"7.22",
"7.17",
"7.15",
"7.14",
"7.12",
"7.10",
"7.9",
"7.8",
"7.7",
"7.6",
"7.4",
"7.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-6928.json"
}
}
],
"modified": "2026-10-24T10:30:27.720881173Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html",
"https://www.drupal.org/sa-core-2018-001",
"https://www.debian.org/security/2018/dsa-4123"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "7.0"
},
{
"last_affected": "7.0"
},
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2017-6928",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 431884,
"published_at": "2018-03-01T23:29:00.357+00:00"
}