LifterLMS <= 8.0.1 - Missing Authorization to Unauthenticated Post Trashing
The LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes plugin for WordPress is vulnerable to Unauthenticated Post Trashing due to a missing capability check on the delete_access_plan function and the related AJAX calls in all versions up to, and including, 8.0.1. This makes it possible for unauthenticated attackers to change status to "Trash" for every published post, therefore limiting the availability of the website's content.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-2290
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 11:35 UTC · Revision 1
Source evidence
LifterLMS <= 8.0.1 - Missing Authorization to Unauthenticated Post Trashing
core-osv · Original sourcePublished 19 Mar 2025, 04:21 UTC
The LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes plugin for WordPress is vulnerable to Unauthenticated Post Trashing due to a missing capability check on the delete_access_plan function and the related AJAX calls in all versions up to, and including, 8.0.1. This makes it possible for unauthenticated attackers to change status to "Trash" for every published post, therefore limiting the availability of the website's content.
osv:CVE-2025-2290
Complete source record
{
"id": "b3833c4206b1d3d380f1400f51b812899c160046a5b488f75f939cc4bc5e4b67",
"url": "https://osv.dev/vulnerability/CVE-2025-2290",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "LifterLMS <= 8.0.1 - Missing Authorization to Unauthenticated Post Trashing",
"summary": "The LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes plugin for WordPress is vulnerable to Unauthenticated Post Trashing due to a missing capability check on the delete_access_plan function and the related AJAX calls in all versions up to, and including, 8.0.1. This makes it possible for unauthenticated attackers to change status to \"Trash\" for every published post, therefore limiting the availability of the website's content.",
"evidence": "osv:CVE-2025-2290",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-2290",
"aliases": [
"CVE-2025-2290"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/gocodebox/lifterlms",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "73762bf34ed62199f8323e46a317558d6253d9f9"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:lifterlms:lifterlms:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "8.0.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"@lifterlms/scripts@2.2.0",
"@lifterlms/llms-e2e-test-utils@3.2.0",
"@lifterlms/dev@0.0.4-alpha.0",
"@lifterlms/brand@0.0.2",
"@lifterlms/scripts@1.3.7",
"@lifterlms/llms-e2e-test-utils@2.2.3",
"@lifterlms/brand@0.0.1",
"@lifterlms/scripts@1.3.5",
"@lifterlms/llms-e2e-test-utils@2.2.2",
"@lifterlms/llms-e2e-test-utils@2.1.3",
"@lifterlms/scripts@1.3.2",
"@lifterlms/scripts@1.3.0",
"@lifterlms/scripts@1.2.4",
"@lifterlms/scripts@1.2.3",
"@lifterlms/llms-e2e-test-utils@2.1.2",
"@lifterlms/scripts@1.2.1",
"@lifterlms/llms-e2e-test-utils@2.1.0",
"@lifterlms/scripts@1.3.1",
"@lifterlms/scripts@1.2.0",
"@lifterlms/llms-e2e-test-utils@2.0.0",
"@lifterlms/llms-e2e-test-utils@1.1.1",
"llms-e2e-test-utils@1.1.0",
"llms-e2e-test-utils@1.0.1",
"llms-e2e-test-utils@1.0.0",
"3.20.0-beta.1",
"3.0.0-beta.5",
"3.0.0-beta.4",
"3.0.0-beta.3",
"3.0.0-beta.2",
"3.0.0-beta.1",
"1.4.0",
"1.3.10",
"1.3.9",
"1.3.8",
"1.3.7",
"1.3.6",
"1.3.5",
"1.3.4",
"v1.3.3",
"1.3.2",
"1.3.0",
"1.2.6",
"1.2.5",
"1.2.4",
"1.1.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-2290.json"
}
}
],
"modified": "2026-10-28T02:30:28.121388205Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/changeset/3257328/lifterlms/trunk/includes/class.llms.ajax.handler.php",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/4f64dbf2-b75a-4a35-9b4e-413b8fd1fff0?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/2xxx/CVE-2025-2290.json",
"https://nvd.nist.gov/vuln/detail/CVE-2025-2290"
],
"provider_metadata": {
"cwe_ids": [
"CWE-862"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "8.0.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/2xxx/CVE-2025-2290.json"
}
},
"related_cves": [
{
"value": "CVE-2025-2290",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 494911,
"published_at": "2025-03-19T04:21:05.815+00:00"
}