Medium
Security advisory
Cross Site Scripting vulnerability in WPEVEREST Everest Forms before 3.0.9 allows an attacker to execute arbitrary code via a file upload.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-26841
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 01:42 UTC · Revision 1
Source evidence
Cross Site Scripting vulnerability in WPEVEREST Everest Forms before 3.0.9 allows an attacker to execute arbitrary code via a file upload.
osv:CVE-2025-26841
Complete source record
{
"id": "66ec9aea9d179a312399cef10aeb083e0522728a0d420d839f3ff5ad05a8f43d",
"url": "https://osv.dev/vulnerability/CVE-2025-26841",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2025-26841",
"summary": "Cross Site Scripting vulnerability in WPEVEREST Everest Forms before 3.0.9 allows an attacker to execute arbitrary code via a file upload.",
"evidence": "osv:CVE-2025-26841",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-26841",
"aliases": [
"CVE-2025-26841"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/themegrill/everest-forms",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "c8ac8dc03fffe8bc8eb3dfb1060342ff8e8c1944"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wpeverest:everest_forms:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.0.9"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"3.0.6",
"3.0.5.2",
"3.0.5.1",
"3.0.5",
"3.0.4.2",
"3.0.4.1",
"3.0.4",
"3.0.3.1",
"3.0.3",
"3.0.2",
"3.0.1",
"3.0.0.1",
"3.0.0",
"2.0.9",
"2.0.8.1",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.3.1",
"2.0.3",
"2.0.1",
"2.0.0.1",
"2.0.0",
"1.9.9",
"1.9.8",
"1.9.7",
"1.9.6",
"1.9.5",
"1.9.4.1",
"1.9.4",
"1.9.3",
"1.9.2",
"1.9.1",
"1.9.0.1",
"1.9.0",
"1.8.9",
"1.8.8",
"1.8.7",
"1.8.6",
"1.8.5",
"1.8.4",
"1.8.3",
"1.8.2.3",
"1.8.2.2",
"1.8.2.1",
"1.8.2",
"1.8.1",
"1.8.0.1",
"1.8.0",
"1.7.9",
"1.7.8",
"1.7.7.2",
"1.7.7.1",
"1.7.7",
"1.7.6",
"1.7.5.2",
"1.7.5.1",
"1.7.5",
"1.7.4",
"1.7.3",
"1.7.2.2",
"1.7.2.1",
"1.7.2",
"1.7.1",
"1.7.0.3",
"1.7.0.2",
"1.7.0.1",
"1.7.0",
"1.6.7",
"1.6.6.1",
"1.6.6",
"1.6.5",
"1.6.4",
"1.6.2",
"1.6.3",
"1.6.1",
"1.6.0",
"1.5.10",
"1.5.9",
"1.5.8",
"1.5.7",
"1.5.6",
"1.5.5",
"1.5.4",
"1.5.2",
"1.5.1",
"1.5.0",
"1.4.9",
"1.4.8",
"1.4.6",
"1.4.5",
"1.4.4",
"1.4.3",
"1.4.2",
"1.4.1",
"1.4.0-beta6",
"1.4.0",
"1.4.0-beta5",
"1.4.0-beta4",
"1.4.0-beta3",
"1.4.0-beta2",
"v1.4.0-beta",
"1.4.0-beta",
"1.3.4",
"1.3.2",
"1.3.0",
"1.2.0",
"1.2.0-rc.1",
"1.1.4",
"1.1.3",
"1.1.0",
"1.1.0-rc.1",
"1.0.2",
"1.0.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-26841.json"
}
}
],
"modified": "2026-10-28T02:30:25.124971330Z",
"provider": "osv",
"references": [
"https://everestforms.net",
"https://gist.github.com/knilkantha/71458e9a787157653d5603fe6880bc05",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/26xxx/CVE-2025-26841.json",
"https://nvd.nist.gov/vuln/detail/CVE-2025-26841"
],
"provider_metadata": {
"cna_assigner": "mitre",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/26xxx/CVE-2025-26841.json"
}
},
"related_cves": [
{
"value": "CVE-2025-26841",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491709,
"published_at": "2025-05-12T00:00:00+00:00"
}