Apache HTTP Server: mod_auth_digest DoS attack
Use after free in mod_auth_digest in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an unauthenticated remote client to cause authentication state corruption via concurrent Digest authentication requests when AuthDigestNcCheck is enabled or AuthDigestNonceLifetime is set to 0. Users are recommended to upgrade to version 2.4.69, which fixes this issue.
- Products
- apache
- Affected versions
- Not specified
- Fixed versions
- 2.4.69
- CVEs
- CVE-2026-73637
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 27 Oct 2026, 11:22 UTC · Revision 1
Source evidence
Apache HTTP Server: mod_auth_digest DoS attack
core-osv · Original sourcePublished 6 Oct 2026, 11:41 UTC
Use after free in mod_auth_digest in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an unauthenticated remote client to cause authentication state corruption via concurrent Digest authentication requests when AuthDigestNcCheck is enabled or AuthDigestNonceLifetime is set to 0. Users are recommended to upgrade to version 2.4.69, which fixes this issue.
osv:BIT-apache-2026-73637
apache
Fixed versions: 2.4.69
Complete source record
{
"id": "8cb7f747f734de8e090b4ab0ceb38593988400249e12d1e86fb4a821e607c43c",
"url": "https://osv.dev/vulnerability/BIT-apache-2026-73637",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache HTTP Server: mod_auth_digest DoS attack",
"summary": "Use after free in mod_auth_digest in Apache Software Foundation Apache HTTP Server before 2.4.69 on all platforms allows an unauthenticated remote client to cause authentication state corruption via concurrent Digest authentication requests when AuthDigestNcCheck is enabled or AuthDigestNonceLifetime is set to 0. Users are recommended to upgrade to version 2.4.69, which fixes this issue.",
"evidence": "osv:BIT-apache-2026-73637",
"products": [
{
"name": {
"value": "apache",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.69",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "BIT-apache-2026-73637",
"aliases": [
"BIT-apache-2026-73637",
"CVE-2026-73637"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "2.4.0"
},
{
"fixed": "2.4.69"
}
]
}
],
"package": {
"name": "apache",
"purl": "pkg:bitnami/apache",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/apache/BIT-apache-2026-73637.json"
}
}
],
"modified": "2026-10-06T15:15:04.483342477Z",
"provider": "osv",
"references": [
"https://httpd.apache.org/security/vulnerabilities_24.html",
"https://nvd.nist.gov/vuln/detail/CVE-2026-73637"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*"
],
"severity": "High"
}
},
"related_cves": [
{
"value": "CVE-2026-73637",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 89114,
"published_at": "2026-10-06T11:41:06.358+00:00"
}