Skip to content
Heist/ feed
Back to feed
Medium

jackrabbit — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2026-92415

— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH). This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.

Products
jackrabbit
Affected versions
2.20.11-1, 2.20.11-1.1, 2.20.3-1
Fixed versions
Not specified
CVEs
CVE-2026-92415
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 11:50 UTC · Revision 1

Source evidence

DEBIAN-CVE-2026-92415

core-osv · Original source

Published 7 Oct 2026, 16:19 UTC

— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH). This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.

osv:DEBIAN-CVE-2026-92415

jackrabbit

Fixed versions: Not specified

jackrabbit

Fixed versions: Not specified

jackrabbit

Fixed versions: Not specified

Complete source record
{
  "id": "7dfb2ae35e5e8f83a3b7d6d50547d6f5ab2fc7a72382154f6179d18b5cf57f7b",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-92415",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2026-92415",
    "summary": "— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH). This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.",
    "evidence": "osv:DEBIAN-CVE-2026-92415",
    "products": [
      {
        "name": {
          "value": "jackrabbit",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "2.20.11-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.20.11-1.1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.20.3-1",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "jackrabbit",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "2.20.11-1.1",
            "evidence": "/affected/1/versions"
          }
        ]
      },
      {
        "name": {
          "value": "jackrabbit",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "2.20.11-1.1",
            "evidence": "/affected/2/versions"
          }
        ]
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2026-92415",
      "aliases": [
        "DEBIAN-CVE-2026-92415"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "jackrabbit",
            "purl": "pkg:deb/debian/jackrabbit?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "versions": [
            "2.20.11-1",
            "2.20.11-1.1",
            "2.20.3-1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-92415.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "jackrabbit",
            "purl": "pkg:deb/debian/jackrabbit?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "versions": [
            "2.20.11-1.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-92415.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "jackrabbit",
            "purl": "pkg:deb/debian/jackrabbit?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "versions": [
            "2.20.11-1.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-92415.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-14T10:00:39.852776519Z",
      "provider": "osv",
      "upstream": [
        "CVE-2026-92415"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2026-92415"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2026-92415",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 315377,
  "published_at": "2026-10-07T16:19:13.07+00:00"
}