DataChain: Deserialization of Untrusted Data from Environment Variables
DataChain is a Python-based AI-data warehouse for transforming and analyzing unstructured data. Versions 0.34.1 and below allow for deseriaization of untrusted data because of the way the DataChain library reads serialized objects from environment variables (such as DATACHAIN__METASTORE and DATACHAIN__WAREHOUSE) in the loader.py module. An attacker with the ability to set these environment variables can trigger code execution when the application loads. This issue is fixed in version 0.34.2.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-61677
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 8 Nov 2026, 02:15 UTC · Revision 1
Source evidence
DataChain: Deserialization of Untrusted Data from Environment Variables
core-osv · Original sourcePublished 3 Oct 2025, 21:18 UTC
DataChain is a Python-based AI-data warehouse for transforming and analyzing unstructured data. Versions 0.34.1 and below allow for deseriaization of untrusted data because of the way the DataChain library reads serialized objects from environment variables (such as DATACHAIN__METASTORE and DATACHAIN__WAREHOUSE) in the loader.py module. An attacker with the ability to set these environment variables can trigger code execution when the application loads. This issue is fixed in version 0.34.2.
osv:CVE-2025-61677
Complete source record
{
"id": "f71a7fc11291edae44dc24d8e081af28eff8d51adfaecdd82365cd60b86d5412",
"url": "https://osv.dev/vulnerability/CVE-2025-61677",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DataChain: Deserialization of Untrusted Data from Environment Variables",
"summary": "DataChain is a Python-based AI-data warehouse for transforming and analyzing unstructured data. Versions 0.34.1 and below allow for deseriaization of untrusted data because of the way the DataChain library reads serialized objects from environment variables (such as DATACHAIN__METASTORE and DATACHAIN__WAREHOUSE) in the loader.py module. An attacker with the ability to set these environment variables can trigger code execution when the application loads. This issue is fixed in version 0.34.2.",
"evidence": "osv:CVE-2025-61677",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2025-61677",
"aliases": [
"CVE-2025-61677",
"GHSA-6px8-mr29-cj4r",
"PYSEC-2026-1288"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/datachain-ai/datachain",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "914b95610620d50c8d9bee506ccbfa7d4d57fdc0"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "0.34.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "914b95610620d50c8d9bee506ccbfa7d4d57fdc0"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"0.34.1",
"0.34.0",
"0.33.1",
"0.33.0",
"0.32.3",
"0.32.2",
"0.32.1",
"0.32.0",
"0.31.4",
"0.31.3",
"0.31.2",
"0.31.1",
"0.31.0",
"0.30.6",
"0.30.7",
"0.30.5",
"0.30.4",
"0.30.3",
"0.30.2",
"0.30.1",
"0.30.0",
"0.29.1",
"0.29.0",
"0.28.2",
"0.28.1",
"0.28.0",
"0.27.0",
"0.26.4",
"0.26.3",
"0.26.2",
"0.26.1",
"0.26.0",
"0.25.2",
"0.25.1",
"0.25.0",
"0.24.6",
"0.24.5",
"0.24.4",
"0.24.3",
"0.24.2",
"0.24.1",
"0.24.0",
"0.23.0",
"0.22.0",
"0.20.4",
"0.20.3",
"0.19.2",
"0.20.2",
"0.20.1",
"0.20.0",
"0.19.1",
"0.19",
"0.18.11",
"0.18.10",
"0.18.9",
"0.18.8",
"0.18.7",
"0.18.6",
"0.18.5",
"0.18.4",
"0.18.3",
"0.18.2",
"0.18.1",
"0.18.0",
"0.17.2",
"0.17.1",
"0.17.0",
"0.16.5",
"0.16.4",
"0.16.3",
"0.16.2",
"0.16.1",
"0.16.0",
"0.15.0",
"0.14.5",
"0.14.4",
"0.14.3",
"0.14.2",
"0.14.1",
"0.14.0",
"0.13.1",
"0.13.0",
"0.12.0",
"0.11.11",
"0.11.0",
"0.10.0",
"0.9.1",
"0.9.0",
"0.8.13",
"0.8.12",
"0.8.11",
"0.8.10",
"0.8.9",
"0.8.8",
"0.8.7",
"0.8.6",
"0.8.5",
"0.8.4",
"0.8.3",
"0.8.2",
"0.8.1",
"0.8.0",
"0.7.11",
"0.7.10",
"0.7.9",
"0.7.6",
"0.7.8",
"0.7.7",
"0.7.5",
"0.7.4",
"0.7.3",
"0.7.2",
"0.7.1",
"0.7.0",
"0.6.11",
"0.6.10",
"0.6.9",
"0.6.8",
"0.6.7",
"0.6.6",
"0.6.5",
"0.6.4",
"0.6.3",
"0.6.2",
"0.6.1",
"0.6.0",
"0.5.1",
"0.5.0",
"0.4.0",
"0.3.20",
"0.3.19",
"0.3.18",
"0.3.17",
"0.3.16",
"0.3.15",
"0.3.14",
"0.3.13",
"0.3.12",
"0.3.11",
"0.3.10",
"0.3.9",
"0.3.8",
"0.3.7",
"0.3.6",
"0.3.5",
"0.3.4",
"0.3.3",
"0.3.2",
"0.3.1",
"0.3.0",
"0.2.18",
"0.2.17",
"0.2.16",
"0.2.15",
"0.2.14",
"0.2.13",
"0.2.12",
"0.2.11",
"0.2.10",
"0.2.9",
"0.2.8",
"0.2.7",
"0.2.6",
"0.2.5"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-61677.json"
}
}
],
"modified": "2026-10-28T02:30:53.006780385Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/61xxx/CVE-2025-61677.json",
"https://github.com/iterative/datachain/security/advisories/GHSA-6px8-mr29-cj4r",
"https://nvd.nist.gov/vuln/detail/CVE-2025-61677",
"https://github.com/iterative/datachain/commit/914b95610620d50c8d9bee506ccbfa7d4d57fdc0",
"https://github.com/iterative/datachain/pull/1358"
],
"provider_metadata": {
"cwe_ids": [
"CWE-502"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/61xxx/CVE-2025-61677.json"
}
},
"related_cves": [
{
"value": "CVE-2025-61677",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 521692,
"published_at": "2025-10-03T21:18:39.67+00:00"
}