caddy — security advisory
Caddy is an extensible server platform that uses TLS by default. Prior to version 2.11.1, Caddy's FastCGI path splitting logic computes the split index on a lowercased copy of the request path and then uses that byte index to slice the original path. This is unsafe for Unicode because `strings.ToLower()` can change UTF-8 byte length for some characters. As a result, Caddy can derive an incorrect `SCRIPT_NAME`/`SCRIPT_FILENAME` and `PATH_INFO`, potentially causing a request that contains `.php` to execute a different on-disk file than intended (path confusion). In setups where an attacker can control file contents (e.g., upload features), this can lead to unintended PHP execution of non-.php files (potential RCE depending on deployment). Version 2.11.1 fixes the issue.
- Products
- caddy
- Affected versions
- 2.11.2-1~bpo13+1, 2.6.2-12, 2.6.2-13, 2.6.2-14, 2.6.2-5
- Fixed versions
- 2.11.2-1, 2.6.2-12+deb13u1, 2.6.2-5+deb12u1
- CVEs
- CVE-2026-27590
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 09:33 UTC · Revision 1
Source evidence
Caddy is an extensible server platform that uses TLS by default. Prior to version 2.11.1, Caddy's FastCGI path splitting logic computes the split index on a lowercased copy of the request path and then uses that byte index to slice the original path. This is unsafe for Unicode because `strings.ToLower()` can change UTF-8 byte length for some characters. As a result, Caddy can derive an incorrect `SCRIPT_NAME`/`SCRIPT_FILENAME` and `PATH_INFO`, potentially causing a request that contains `.php` to execute a different on-disk file than intended (path confusion). In setups where an attacker can control file contents (e.g., upload features), this can lead to unintended PHP execution of non-.php files (potential RCE depending on deployment). Version 2.11.1 fixes the issue.
osv:DEBIAN-CVE-2026-27590
caddy
Fixed versions: 2.6.2-5+deb12u1
caddy
Fixed versions: 2.6.2-12+deb13u1
caddy
Fixed versions: 2.11.2-1
Complete source record
{
"id": "8f91bee4517a1e5ac45ffa8511eceeef572ab4d9ab44bf2c6938b1d991a81d0e",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-27590",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-27590",
"summary": "Caddy is an extensible server platform that uses TLS by default. Prior to version 2.11.1, Caddy's FastCGI path splitting logic computes the split index on a lowercased copy of the request path and then uses that byte index to slice the original path. This is unsafe for Unicode because `strings.ToLower()` can change UTF-8 byte length for some characters. As a result, Caddy can derive an incorrect `SCRIPT_NAME`/`SCRIPT_FILENAME` and `PATH_INFO`, potentially causing a request that contains `.php` to execute a different on-disk file than intended (path confusion). In setups where an attacker can control file contents (e.g., upload features), this can lead to unintended PHP execution of non-.php files (potential RCE depending on deployment). Version 2.11.1 fixes the issue.",
"evidence": "osv:DEBIAN-CVE-2026-27590",
"products": [
{
"name": {
"value": "caddy",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.6.2-5+deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "2.6.2-5",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "caddy",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.6.2-12+deb13u1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "2.6.2-12",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "caddy",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.11.2-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "2.11.2-1~bpo13+1",
"evidence": "/affected/2/versions"
},
{
"value": "2.6.2-12",
"evidence": "/affected/2/versions"
},
{
"value": "2.6.2-13",
"evidence": "/affected/2/versions"
},
{
"value": "2.6.2-14",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2026-27590",
"aliases": [
"DEBIAN-CVE-2026-27590"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.2-5+deb12u1"
}
]
}
],
"package": {
"name": "caddy",
"purl": "pkg:deb/debian/caddy?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.6.2-5"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27590.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.2-12+deb13u1"
}
]
}
],
"package": {
"name": "caddy",
"purl": "pkg:deb/debian/caddy?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.6.2-12"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27590.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.11.2-1"
}
]
}
],
"package": {
"name": "caddy",
"purl": "pkg:deb/debian/caddy?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.11.2-1~bpo13+1",
"2.6.2-12",
"2.6.2-13",
"2.6.2-14"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-27590.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-24T18:00:07.180314132Z",
"provider": "osv",
"upstream": [
"CVE-2026-27590"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-27590"
]
},
"related_cves": [
{
"value": "CVE-2026-27590",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 444075,
"published_at": "2026-02-24T17:29:04.493+00:00"
}