Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-12613

An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the "$cfg['AllowArbitraryServer'] = true" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the "$cfg['ServerDefault'] = 0" case (which bypasses the login requirement and runs the vulnerable code without any authentication).

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-12613
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 06:44 UTC · Revision 1

Source evidence

CVE-2018-12613

core-osv · Original source

Published 21 Jun 2018, 20:29 UTC

An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the "$cfg['AllowArbitraryServer'] = true" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the "$cfg['ServerDefault'] = 0" case (which bypasses the login requirement and runs the vulnerable code without any authentication).

osv:CVE-2018-12613
Complete source record
{
  "id": "2dc472cc2095c04013c3b5e9686860501220e89c4e2bbe2313da841df80664ee",
  "url": "https://osv.dev/vulnerability/CVE-2018-12613",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-12613",
    "summary": "An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the \"$cfg['AllowArbitraryServer'] = true\" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the \"$cfg['ServerDefault'] = 0\" case (which bypasses the login requirement and runs the vulnerable code without any authentication).",
    "evidence": "osv:CVE-2018-12613",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2018-12613",
      "aliases": [
        "CVE-2018-12613",
        "GHSA-x394-g9j8-x7mf"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/phpmyadmin/phpmyadmin",
              "type": "GIT",
              "events": [
                {
                  "introduced": "9d6ac04ae8cd7064c28c93a6a949cb5324899593"
                },
                {
                  "fixed": "3115f340b933ab95e75785af02d6d497a04f47b3"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "4.8.0"
                      },
                      {
                        "fixed": "4.8.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-12613.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:43.830458807Z",
      "provider": "osv",
      "references": [
        "https://security.gentoo.org/glsa/201904-16",
        "https://www.exploit-db.com/exploits/44928/",
        "https://www.phpmyadmin.net/security/PMASA-2018-4/",
        "https://www.exploit-db.com/exploits/44924/",
        "https://www.exploit-db.com/exploits/45020/"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2018-12613",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 435718,
  "published_at": "2018-06-21T20:29:00.327+00:00"
}