Security advisory
The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-23556
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:41 UTC · Revision 1
Source evidence
The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.
osv:CVE-2021-23556
Complete source record
{
"id": "1b2d1c6fffcc3d7497b365a74e24a7aa80897827d6472e6af56ad1bcc32351f8",
"url": "https://osv.dev/vulnerability/CVE-2021-23556",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-23556",
"summary": "The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.",
"evidence": "osv:CVE-2021-23556",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-23556",
"aliases": [
"CVE-2021-23556",
"GHSA-7x48-7466-3g33",
"PYSEC-2022-165",
"SNYK-PYTHON-GUAKE-2386334"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/guake/guake",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "c48caa7a39f511a617b9541b88ef59bab6a21264"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:guake-project:guake:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.8.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"3.8.5.0rc2",
"3.8.5.0rc1",
"3.8.4",
"3.8.3",
"3.8.2",
"3.8.2.0rc1",
"3.8.1",
"3.8.0",
"3.8.0.0rc3",
"3.8.0.0rc2",
"3.8.0.0rc1",
"3.7.0",
"3.6.3",
"3.6.2",
"3.6.1",
"3.6.0",
"3.5.0",
"3.0.5",
"3.4.0",
"3.3.3",
"3.3.2",
"3.3.1",
"3.3.0",
"3.2.2",
"3.2.1",
"3.2.0",
"3.1.1",
"3.1.0",
"3.0.4",
"3.0.3",
"3.0.2",
"3.0.1",
"3.0.0",
"3.0.0.b2",
"3.0.0.b1",
"3.0.0.a5",
"3.0.0.a4",
"3.0.0-a4",
"0.8.11",
"0.8.10",
"0.8.9",
"0.4.4",
"0.4.3",
"0.4.2",
"0.4.1",
"0.4.0",
"0.3.0",
"first_alpha_release"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-23556.json"
}
}
],
"modified": "2026-10-20T10:54:32.987824696Z",
"provider": "osv",
"references": [
"https://github.com/Guake/guake/releases",
"https://github.com/Guake/guake/issues/1796",
"https://github.com/Guake/guake/pull/2017",
"https://github.com/Guake/guake/pull/2017/commits/e3d671120bfe7ba28f50e256cc5e8a629781b888",
"https://snyk.io/vuln/SNYK-PYTHON-GUAKE-2386334"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-23556",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385552,
"published_at": "2022-03-17T12:15:07.59+00:00"
}