HighFix available
mod-wsgi — security advisory
mod_wsgi module before 3.4 for Apache, when used in embedded mode, might allow remote attackers to obtain sensitive information via the Content-Type header which is generated from memory that may have been freed and then overwritten by a separate thread.
- Products
- mod-wsgi
- Affected versions
- Not specified
- Fixed versions
- 3.4-3
- CVEs
- CVE-2014-0242
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:50 UTC · Revision 1
Source evidence
mod_wsgi module before 3.4 for Apache, when used in embedded mode, might allow remote attackers to obtain sensitive information via the Content-Type header which is generated from memory that may have been freed and then overwritten by a separate thread.
osv:DEBIAN-CVE-2014-0242
mod-wsgi
Fixed versions: 3.4-3
mod-wsgi
Fixed versions: 3.4-3
mod-wsgi
Fixed versions: 3.4-3
Complete source record
{
"id": "993499de3298f32470d57961ff7e9389e59488f05c49582ae9df20657c697815",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-0242",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-0242",
"summary": "mod_wsgi module before 3.4 for Apache, when used in embedded mode, might allow remote attackers to obtain sensitive information via the Content-Type header which is generated from memory that may have been freed and then overwritten by a separate thread.",
"evidence": "osv:DEBIAN-CVE-2014-0242",
"products": [
{
"name": {
"value": "mod-wsgi",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.4-3",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mod-wsgi",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.4-3",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mod-wsgi",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.4-3",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2014-0242",
"aliases": [
"DEBIAN-CVE-2014-0242"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4-3"
}
]
}
],
"package": {
"name": "mod-wsgi",
"purl": "pkg:deb/debian/mod-wsgi?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0242.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4-3"
}
]
}
],
"package": {
"name": "mod-wsgi",
"purl": "pkg:deb/debian/mod-wsgi?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0242.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.4-3"
}
]
}
],
"package": {
"name": "mod-wsgi",
"purl": "pkg:deb/debian/mod-wsgi?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0242.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T16:00:15.007929280Z",
"provider": "osv",
"upstream": [
"CVE-2014-0242"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-0242"
]
},
"related_cves": [
{
"value": "CVE-2014-0242",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 414644,
"published_at": "2019-12-09T20:15:09.623+00:00"
}