Skip to content
Heist/ feed
Back to feed
HighFix available

Apache Tomcat: Directory traversal via rewrite with possible RCE if PUT is enabled

Type: advisorySources: OSV

Relative Path Traversal vulnerability in Apache Tomcat. The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI. This issue affects Apache Tomcat: from 11.0.0 through 11.0.10, from 10.1.0 through 10.1.44, from 9.0.0 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

Products
tomcat
Affected versions
Not specified
Fixed versions
10.1.45, 11.0.11, 9.0.109
CVEs
CVE-2025-55752
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 19:55 UTC · Revision 1

Source evidence

Apache Tomcat: Directory traversal via rewrite with possible RCE if PUT is enabled

core-osv · Original source

Published 6 Nov 2025, 13:00 UTC

Relative Path Traversal vulnerability in Apache Tomcat. The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI. This issue affects Apache Tomcat: from 11.0.0 through 11.0.10, from 10.1.0 through 10.1.44, from 9.0.0 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

osv:BIT-tomcat-2025-55752

tomcat

Fixed versions: 9.0.109, 10.1.45, 11.0.11

Complete source record
{
  "id": "473dbea612e121c7742bf27e9e3ca0425c2b6c9039b02b9ff60622f4552c640b",
  "url": "https://osv.dev/vulnerability/BIT-tomcat-2025-55752",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Tomcat: Directory traversal via rewrite with possible RCE if PUT is enabled",
    "summary": "Relative Path Traversal vulnerability in Apache Tomcat. The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI. This issue affects Apache Tomcat: from 11.0.0 through 11.0.10, from 10.1.0 through 10.1.44, from 9.0.0 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.",
    "evidence": "osv:BIT-tomcat-2025-55752",
    "products": [
      {
        "name": {
          "value": "tomcat",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "9.0.109",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "10.1.45",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "11.0.11",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "BIT-tomcat-2025-55752",
      "aliases": [
        "BIT-tomcat-2025-55752",
        "CVE-2025-55752",
        "GHSA-wmwf-9ccg-fff5"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "9.0.109"
                },
                {
                  "introduced": "10.0.0"
                },
                {
                  "fixed": "10.1.45"
                },
                {
                  "introduced": "11.0.0"
                },
                {
                  "fixed": "11.0.11"
                }
              ]
            }
          ],
          "package": {
            "name": "tomcat",
            "purl": "pkg:bitnami/tomcat",
            "ecosystem": "Bitnami"
          },
          "severity": [
            {
              "type": "CVSS_V3",
              "score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H"
            }
          ],
          "database_specific": {
            "source": "https://github.com/bitnami/vulndb/tree/main/data/tomcat/BIT-tomcat-2025-55752.json"
          }
        }
      ],
      "modified": "2026-10-16T09:45:33.520510620Z",
      "provider": "osv",
      "references": [
        "https://lists.apache.org/thread/n05kjcwyj1s45ovs8ll1qrrojhfb1tog",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-55752",
        "https://www.vicarius.io/vsociety/posts/cve-2025-55752-detect-apache-tomcat-vulnerability",
        "https://www.vicarius.io/vsociety/posts/cve-2025-55752-mitigate-apache-tomcat-vulnerability"
      ],
      "provider_metadata": {
        "cpes": [
          "cpe:2.3:a:apache:tomcat:*:*:*:*:*:maven:*:*"
        ],
        "severity": "High"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-55752",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 338513,
  "published_at": "2025-11-06T13:00:31.694+00:00"
}