Skip to content
Heist/ feed
Back to feed
High

Visionatrix Vulnerable to Reflected XSS Leading to Exfiltration of Secrets

Type: advisorySources: OSV

Visionatrix is an AI Media processing tool using ComfyUI. In versions 1.5.0 to before 2.5.1, the /docs/flows endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack allowing full takeover of the application and exfiltration of secrets stored in the application. The implementation uses the get_swagger_ui_html function from FastAPI. This function does not encode or sanitize its arguments before using them to generate the HTML for the swagger documentation page and is not intended to be used with user-controlled arguments. Any user of this application can be targeted with a one-click attack that can takeover their session and all the secrets that may be contained within it. This issue has been patched in version 2.5.1.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-49126
Confirmed fixed CVEs
Not specified
Updated in this feed
8 Nov 2026, 02:14 UTC · Revision 1

Source evidence

Visionatrix Vulnerable to Reflected XSS Leading to Exfiltration of Secrets

core-osv · Original source

Published 23 Jun 2025, 17:18 UTC

Visionatrix is an AI Media processing tool using ComfyUI. In versions 1.5.0 to before 2.5.1, the /docs/flows endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack allowing full takeover of the application and exfiltration of secrets stored in the application. The implementation uses the get_swagger_ui_html function from FastAPI. This function does not encode or sanitize its arguments before using them to generate the HTML for the swagger documentation page and is not intended to be used with user-controlled arguments. Any user of this application can be targeted with a one-click attack that can takeover their session and all the secrets that may be contained within it. This issue has been patched in version 2.5.1.

osv:CVE-2025-49126
Complete source record
{
  "id": "cc01199e95cf3d0ce566584d85eaa8eaa38a4ccf178d4abe25d533e5a2b14d5f",
  "url": "https://osv.dev/vulnerability/CVE-2025-49126",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Visionatrix Vulnerable to Reflected XSS Leading to Exfiltration of Secrets",
    "summary": "Visionatrix is an AI Media processing tool using ComfyUI. In versions 1.5.0 to before 2.5.1, the /docs/flows endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack allowing full takeover of the application and exfiltration of secrets stored in the application. The implementation uses the get_swagger_ui_html function from FastAPI. This function does not encode or sanitize its arguments before using them to generate the HTML for the swagger documentation page and is not intended to be used with user-controlled arguments. Any user of this application can be targeted with a one-click attack that can takeover their session and all the secrets that may be contained within it. This issue has been patched in version 2.5.1.",
    "evidence": "osv:CVE-2025-49126",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-49126",
      "aliases": [
        "CVE-2025-49126",
        "GHSA-w36r-9jvx-q48v"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/visionatrix/visionatrix",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0b57c39c50034600008245a069b613b19a80f257"
                },
                {
                  "fixed": "63aafe6e4d1bffe4bf69e73b6fdfc65c71a8f5b8"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "1.5.0"
                      },
                      {
                        "fixed": "2.5.1"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "63aafe6e4d1bffe4bf69e73b6fdfc65c71a8f5b8"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.5.1"
                      }
                    ],
                    "source": "DESCRIPTION"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.5.0",
            "v2.4.1",
            "v2.4.0",
            "v2.3.0",
            "v2.2.0",
            "v2.1.0",
            "v2.0.1.dev0",
            "v2.0.0",
            "v1.11.1",
            "v1.11.0",
            "v1.10.0",
            "v1.9.0",
            "v1.8.0",
            "v1.7.0",
            "v1.6.0",
            "v1.5.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-49126.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:53.135446633Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/49xxx/CVE-2025-49126.json",
        "https://github.com/Visionatrix/Visionatrix/security/advisories/GHSA-w36r-9jvx-q48v",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-49126",
        "https://github.com/Visionatrix/Visionatrix/commit/63aafe6e4d1bffe4bf69e73b6fdfc65c71a8f5b8"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/49xxx/CVE-2025-49126.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-49126",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 521687,
  "published_at": "2025-06-23T17:18:51.857+00:00"
}