Medium
Security advisory
The magic-fields plugin before 1.7.2 for WordPress has XSS via the RCCWP_CreateCustomFieldPage.php custom-group-id parameter.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-18610
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:29 UTC · Revision 1
Source evidence
The magic-fields plugin before 1.7.2 for WordPress has XSS via the RCCWP_CreateCustomFieldPage.php custom-group-id parameter.
osv:CVE-2017-18610
Complete source record
{
"id": "e4c10dfdc802b1edf1779e70faaeb9a09c489e810a372122c7957d4c32fe4a3b",
"url": "https://osv.dev/vulnerability/CVE-2017-18610",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-18610",
"summary": "The magic-fields plugin before 1.7.2 for WordPress has XSS via the RCCWP_CreateCustomFieldPage.php custom-group-id parameter.",
"evidence": "osv:CVE-2017-18610",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2017-18610",
"aliases": [
"CVE-2017-18610"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/hunk/magic-fields",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "8f7d34c2b5f47fba9803f98f07c8b90d3a7302db"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:magicfields:magic_fields:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.7.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"1.7.1",
"1.7",
"v1.5.5",
"v1.5.2",
"v1.5RC",
"v1.4",
"1.3",
"v1.4-beta",
"1.3-beta",
"1.1",
"1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-18610.json"
}
}
],
"modified": "2026-10-24T10:30:29.483134465Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins/magic-fields/#developers",
"https://sumofpwn.nl/advisory/2016/cross_site_scripting_in_magic_fields_1_wordpress_plugin.html"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2017-18610",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 432335,
"published_at": "2019-09-10T12:15:11.323+00:00"
}