HighFix available
pgbouncer — security advisory
When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.
- Products
- pgbouncer
- Affected versions
- Not specified
- Fixed versions
- 1.16.1-1
- CVEs
- CVE-2021-3935
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:39 UTC · Revision 1
Source evidence
When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.
osv:DEBIAN-CVE-2021-3935
pgbouncer
Fixed versions: 1.16.1-1
pgbouncer
Fixed versions: 1.16.1-1
pgbouncer
Fixed versions: 1.16.1-1
Complete source record
{
"id": "127960fcd212d89896d3ed62d1dd043d60e6114822233eb07efdba71f6ffaace",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-3935",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-3935",
"summary": "When PgBouncer is configured to use \"cert\" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.",
"evidence": "osv:DEBIAN-CVE-2021-3935",
"products": [
{
"name": {
"value": "pgbouncer",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.16.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "pgbouncer",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.16.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "pgbouncer",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.16.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2021-3935",
"aliases": [
"DEBIAN-CVE-2021-3935"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.16.1-1"
}
]
}
],
"package": {
"name": "pgbouncer",
"purl": "pkg:deb/debian/pgbouncer?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3935.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.16.1-1"
}
]
}
],
"package": {
"name": "pgbouncer",
"purl": "pkg:deb/debian/pgbouncer?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3935.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.16.1-1"
}
]
}
],
"package": {
"name": "pgbouncer",
"purl": "pkg:deb/debian/pgbouncer?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3935.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:32.352978482Z",
"provider": "osv",
"upstream": [
"CVE-2021-3935"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-3935"
]
},
"related_cves": [
{
"value": "CVE-2021-3935",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 421838,
"published_at": "2021-11-22T16:15:07.44+00:00"
}