spotipy — security advisory
Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.
- Products
- spotipy
- Affected versions
- 2.25.1-1, 2.25.2-1, 2.26.0-1
- Fixed versions
- Not specified
- CVEs
- CVE-2025-66040
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 01:49 UTC · Revision 1
Source evidence
Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.
osv:UBUNTU-CVE-2025-66040
spotipy
Fixed versions: Not specified
spotipy
Fixed versions: Not specified
spotipy
Fixed versions: Not specified
Complete source record
{
"id": "15522723cb393bf82555e4d6fe82249163c21817af285455d4bb44b5b23d100d",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2025-66040",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2025-66040",
"summary": "Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.",
"evidence": "osv:UBUNTU-CVE-2025-66040",
"products": [
{
"name": {
"value": "spotipy",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.25.1-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "spotipy",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.25.2-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.26.0-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "spotipy",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.25.1-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.25.2-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "low",
"structured": {
"id": "UBUNTU-CVE-2025-66040",
"aliases": [
"UBUNTU-CVE-2025-66040"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "spotipy",
"purl": "pkg:deb/ubuntu/spotipy?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"2.25.1-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-66040.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "python3-spotipy",
"binary_version": "2.25.1-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "spotipy",
"purl": "pkg:deb/ubuntu/spotipy?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"2.25.2-1",
"2.26.0-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-66040.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "python3-spotipy",
"binary_version": "2.26.0-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "spotipy",
"purl": "pkg:deb/ubuntu/spotipy?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"2.25.1-1",
"2.25.2-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-66040.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "python3-spotipy",
"binary_version": "2.25.2-1"
}
]
}
}
],
"modified": "2026-10-17T12:57:29.393556736Z",
"provider": "osv",
"upstream": [
"CVE-2025-66040"
],
"references": [
"https://ubuntu.com/security/CVE-2025-66040",
"https://www.cve.org/CVERecord?id=CVE-2025-66040",
"https://github.com/spotipy-dev/spotipy/security/advisories/GHSA-r77h-rpp9-w2xm",
"https://github.com/spotipy-dev/spotipy/commit/880b92d7243dcf2b83bf31dc365a858d8b5e6767"
]
},
"related_cves": [
{
"value": "CVE-2025-66040",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 357602,
"published_at": "2025-11-27T00:15:00+00:00"
}