Critical
Security advisory
A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-7550
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:19 UTC · Revision 1
Source evidence
A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.
osv:CVE-2017-7550
Complete source record
{
"id": "69d741908b92a91705c485d597c22f24321a2a3e6e38184b32fd0cc8abd8e65d",
"url": "https://osv.dev/vulnerability/CVE-2017-7550",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-7550",
"summary": "A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the \"params\" argument, and noting this in the module documentation.",
"evidence": "osv:CVE-2017-7550",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2017-7550",
"aliases": [
"CVE-2017-7550",
"GHSA-588w-w6mv-3cw5",
"PYSEC-2017-4"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/ansible/ansible",
"type": "GIT",
"events": [
{
"introduced": "d56ba0945dbf6c787a3e7f3e17b3db657b9dcee4"
},
{
"fixed": "0255ab2e27d1268faa409bff855682f2992f0f85"
},
{
"introduced": "d14467b0294296b9a2b85e0ad150315c2d5a2491"
},
{
"fixed": "e946c4b3b73be28871ab67965584e060d7da1c4b"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.3.0"
},
{
"fixed": "2.3.3"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.4.0"
},
{
"fixed": "2.4.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.3.3.0-0.3.rc3",
"v2.4.1.0-0.4.rc2",
"v2.3.3.0-0.2.rc2",
"v2.3.3.0-0.1.rc1",
"v2.4.1.0-0.3.rc1",
"v2.4.1.0-0.2.beta2",
"v2.4.1.0-0.1.beta1",
"v2.4.0.0-1",
"v2.3.2.0-1",
"v2.3.2.0-0.5.rc5",
"v2.3.2.0-0.4.rc4",
"v2.3.2.0-0.3.rc3",
"v2.3.2.0-0.2.rc2",
"v2.3.2.0-0.1.rc1",
"v2.3.1.0-1",
"v2.3.1.0-0.2.rc2",
"v2.3.1.0-0.1.rc1",
"v2.3.0.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-7550.json"
}
}
],
"modified": "2026-10-20T10:50:09.634572847Z",
"provider": "osv",
"references": [
"https://access.redhat.com/errata/RHSA-2017:2966",
"https://bugzilla.redhat.com/show_bug.cgi?id=1473645",
"https://github.com/ansible/ansible/issues/30874"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:*"
],
"vendor_product": "redhat:enterprise_linux_server",
"extracted_events": [
{
"range": [
{
"introduced": "7.0"
},
{
"last_affected": "7.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2017-7550",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 381362,
"published_at": "2017-11-21T17:29:00.21+00:00"
}