LaRecipe is vulnerable to Server-Side Template Injection attacks
LaRecipe is an application that allows users to create documentation with Markdown inside a Laravel app. Versions prior to 2.8.1 are vulnerable to Server-Side Template Injection (SSTI), which could potentially lead to Remote Code Execution (RCE) in vulnerable configurations. Attackers could execute arbitrary commands on the server, access sensitive environment variables, and/or escalate access depending on server configuration. Users are strongly advised to upgrade to version v2.8.1 or later to receive a patch.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-53833
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 01:09 UTC · Revision 1
Source evidence
LaRecipe is vulnerable to Server-Side Template Injection attacks
core-osv · Original sourcePublished 14 Jul 2025, 22:56 UTC
LaRecipe is an application that allows users to create documentation with Markdown inside a Laravel app. Versions prior to 2.8.1 are vulnerable to Server-Side Template Injection (SSTI), which could potentially lead to Remote Code Execution (RCE) in vulnerable configurations. Attackers could execute arbitrary commands on the server, access sensitive environment variables, and/or escalate access depending on server configuration. Users are strongly advised to upgrade to version v2.8.1 or later to receive a patch.
osv:CVE-2025-53833
Complete source record
{
"id": "3a104f38ffd840e2f158745e9d8aae3dd2d89fa1f2dab9274a4ff1ac0fccc51f",
"url": "https://osv.dev/vulnerability/CVE-2025-53833",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "LaRecipe is vulnerable to Server-Side Template Injection attacks",
"summary": "LaRecipe is an application that allows users to create documentation with Markdown inside a Laravel app. Versions prior to 2.8.1 are vulnerable to Server-Side Template Injection (SSTI), which could potentially lead to Remote Code Execution (RCE) in vulnerable configurations. Attackers could execute arbitrary commands on the server, access sensitive environment variables, and/or escalate access depending on server configuration. Users are strongly advised to upgrade to version v2.8.1 or later to receive a patch.",
"evidence": "osv:CVE-2025-53833",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2025-53833",
"aliases": [
"CVE-2025-53833",
"GHSA-jv7x-xhv2-p5v2"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/saleem-hadad/larecipe",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "c1d0d56889655ce5f2645db5acf0e78d5fc3b36b"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.8.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "c1d0d56889655ce5f2645db5acf0e78d5fc3b36b"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.8.1"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"v2.8.0",
"v2.7.0",
"v2.6.1",
"v2.6.0",
"v2.5.0",
"v2.4.4",
"v2.4.3",
"v2.4.2",
"v2.4.1",
"v2.4.0",
"v2.3.0",
"v2.2.3",
"v2.2.2",
"v2.2.1",
"v2.2.0",
"v2.1.2",
"v2.1.1",
"v2.1.0",
"v1.4.0",
"v1.3.6",
"v1.3.5",
"v1.3.4",
"v1.3.3",
"v1.3.2",
"v1.3.1",
"v1.2.5",
"v1.2.4",
"v1.2.3",
"v1.2.2",
"v1.2.1",
"v1.2.0",
"v1.1.0",
"v1.0.1",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-53833.json"
}
}
],
"modified": "2026-10-28T02:30:24.738470185Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/53xxx/CVE-2025-53833.json",
"https://github.com/saleem-hadad/larecipe/security/advisories/GHSA-jv7x-xhv2-p5v2",
"https://nvd.nist.gov/vuln/detail/CVE-2025-53833",
"https://github.com/saleem-hadad/larecipe/commit/c1d0d56889655ce5f2645db5acf0e78d5fc3b36b",
"https://github.com/saleem-hadad/larecipe/pull/390"
],
"provider_metadata": {
"cwe_ids": [
"CWE-1336"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/53xxx/CVE-2025-53833.json"
}
},
"related_cves": [
{
"value": "CVE-2025-53833",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491445,
"published_at": "2025-07-14T22:56:38.957+00:00"
}