Post SMTP <= 3.1.2 - Authenticated (Administrator+) SQL Injection via columns Parameter
The Post SMTP plugin for WordPress is vulnerable to generic SQL Injection via the ‘columns’ parameter in all versions up to, and including, 3.1.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-13844
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 17:40 UTC · Revision 1
Source evidence
Post SMTP <= 3.1.2 - Authenticated (Administrator+) SQL Injection via columns Parameter
core-osv · Original sourcePublished 8 Mar 2025, 05:30 UTC
The Post SMTP plugin for WordPress is vulnerable to generic SQL Injection via the ‘columns’ parameter in all versions up to, and including, 3.1.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
osv:CVE-2024-13844
Complete source record
{
"id": "adb475230f0543a5749e63c2d475567ea4b8191da8350e0ac90c2014f2ab6019",
"url": "https://osv.dev/vulnerability/CVE-2024-13844",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Post SMTP <= 3.1.2 - Authenticated (Administrator+) SQL Injection via columns Parameter",
"summary": "The Post SMTP plugin for WordPress is vulnerable to generic SQL Injection via the ‘columns’ parameter in all versions up to, and including, 3.1.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.",
"evidence": "osv:CVE-2024-13844",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-13844",
"aliases": [
"CVE-2024-13844"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wpexpertsio/post-smtp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "a21d9ca05b7d06afc9af2715c692d63c077b5308"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wpexperts:post_smtp:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.1.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"3.1.2",
"3.1.1",
"3.1.0",
"3.0.1",
"3.0.0",
"3.0.0-rc.1",
"3.0.0-beta.1",
"2.9.9",
"2.9.8",
"2.9.7",
"2.9.6",
"2.9.5",
"2.5.9-beta.1",
"2.9.3",
"2.9.2",
"2.9.1",
"2.9.0",
"2.8.8",
"2.8.7",
"2.8.5",
"2.8.4",
"2.7.0",
"2.8.3",
"2.7.2",
"2.6.0",
"2.5.9.4",
"2.5.9.3",
"2.5.8",
"2.5.7",
"2.5.6",
"2.5.5",
"2.5.4",
"2.5.3",
"2.5.2",
"2.5.1",
"2.5.0",
"2.5-rc.3",
"2.5-rc.2",
"2.5-rc.1",
"2.5-beta.1",
"2.4.3",
"2.4.2-beta.2",
"2.4.2",
"2.4.1",
"2.4",
"2.4-beta.1",
"2.3.1",
"2.3",
"2.2.1",
"2.2",
"2.2-beta.2",
"2.1.8",
"2.1.7",
"2.1.6",
"2.1.4",
"2.1.4-rc.2",
"2.1.4-rc.1",
"2.1.4-beta.1",
"2.1.2",
"2.1.2-rc.2",
"2.1.2-rc.1",
"2.1.2-beta-1",
"2.1.1.1",
"2.1.1",
"2.1",
"2.1-beta.1",
"2.0.27",
"2.0.26",
"2.0.25-beta.1",
"2.0.25",
"2.0.24",
"2.0.23",
"2.0.22",
"2.0.21",
"2.0.20",
"2.0.19",
"2.0.18",
"2.0.17",
"2.0.16",
"2.0.15",
"2.0.14",
"2.0.13",
"2.0.12",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"v1.9.8",
"v1.9.7",
"v1.9.6",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v.1.9.2",
"v.1.9.1",
"v.1.9.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-13844.json"
}
}
],
"modified": "2026-10-28T02:30:37.970096187Z",
"provider": "osv",
"references": [
"https://gist.github.com/nhienit2010/d4692062f54b89e16aa068a0ef142cf6#file-postmanemailquerylog-php-L314",
"https://plugins.trac.wordpress.org/changeset/3249371/",
"https://wordpress.org/plugins/post-smtp/#developers",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/0540f70d-009a-4776-8717-f096e30a11d3?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/13xxx/CVE-2024-13844.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-13844"
],
"provider_metadata": {
"cwe_ids": [
"CWE-89"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "3.1.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/13xxx/CVE-2024-13844.json"
}
},
"related_cves": [
{
"value": "CVE-2024-13844",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 505417,
"published_at": "2025-03-08T05:30:08.283+00:00"
}