podman — security advisory
Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.
- Products
- podman
- Affected versions
- 5.4.1+ds1-1, 5.4.2+ds1-1, 5.4.2+ds1-2, 5.7.0+ds2-3, 5.7.0+ds2-3build1, 5.8.3+ds1-1, 5.8.4+ds1-1, 5.8.6+ds1-2
- Fixed versions
- Not specified
- CVEs
- CVE-2026-33414
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 02:07 UTC · Revision 1
Source evidence
Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.
osv:UBUNTU-CVE-2026-33414
podman
Fixed versions: Not specified
podman
Fixed versions: Not specified
podman
Fixed versions: Not specified
Complete source record
{
"id": "abe1c8edbda8f2c9549b9b711f99b585200c55c1bbea233f369944ff1753a301",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-33414",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-33414",
"summary": "Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.",
"evidence": "osv:UBUNTU-CVE-2026-33414",
"products": [
{
"name": {
"value": "podman",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.4.1+ds1-1",
"evidence": "/affected/0/versions"
},
{
"value": "5.4.2+ds1-1",
"evidence": "/affected/0/versions"
},
{
"value": "5.4.2+ds1-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "podman",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.7.0+ds2-3build1",
"evidence": "/affected/1/versions"
},
{
"value": "5.8.3+ds1-1",
"evidence": "/affected/1/versions"
},
{
"value": "5.8.4+ds1-1",
"evidence": "/affected/1/versions"
},
{
"value": "5.8.6+ds1-2",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "podman",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.4.2+ds1-2",
"evidence": "/affected/2/versions"
},
{
"value": "5.7.0+ds2-3",
"evidence": "/affected/2/versions"
},
{
"value": "5.7.0+ds2-3build1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "UBUNTU-CVE-2026-33414",
"aliases": [
"UBUNTU-CVE-2026-33414"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:L/AC:H/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "podman",
"purl": "pkg:deb/ubuntu/podman?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"5.4.1+ds1-1",
"5.4.2+ds1-1",
"5.4.2+ds1-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-33414.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "podman",
"binary_version": "5.4.2+ds1-2"
},
{
"binary_name": "podman-docker",
"binary_version": "5.4.2+ds1-2"
},
{
"binary_name": "podman-remote",
"binary_version": "5.4.2+ds1-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "podman",
"purl": "pkg:deb/ubuntu/podman?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"5.7.0+ds2-3build1",
"5.8.3+ds1-1",
"5.8.4+ds1-1",
"5.8.6+ds1-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-33414.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "podman",
"binary_version": "5.8.6+ds1-2"
},
{
"binary_name": "podman-docker",
"binary_version": "5.8.6+ds1-2"
},
{
"binary_name": "podman-remote",
"binary_version": "5.8.6+ds1-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "podman",
"purl": "pkg:deb/ubuntu/podman?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"5.4.2+ds1-2",
"5.7.0+ds2-3",
"5.7.0+ds2-3build1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-33414.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "podman",
"binary_version": "5.7.0+ds2-3build1"
},
{
"binary_name": "podman-docker",
"binary_version": "5.7.0+ds2-3build1"
},
{
"binary_name": "podman-remote",
"binary_version": "5.7.0+ds2-3build1"
}
]
}
}
],
"modified": "2026-10-17T12:58:10.662851426Z",
"provider": "osv",
"upstream": [
"CVE-2026-33414"
],
"references": [
"https://ubuntu.com/security/CVE-2026-33414",
"https://www.cve.org/CVERecord?id=CVE-2026-33414",
"https://github.com/containers/podman/security/advisories/GHSA-hc8w-h2mf-hp59",
"https://github.com/containers/podman/commit/571c842bd357ee626019ea97d030fb772fc654ed"
]
},
"related_cves": [
{
"value": "CVE-2026-33414",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/1/score"
},
"source_id": "core-osv",
"document_id": 358287,
"published_at": "2026-04-14T23:16:00+00:00"
}