Medium
Security advisory
An issue was discovered in the gon gem before gon-6.4.0 for Ruby. MultiJson does not honor the escape_mode parameter to escape fields as an XSS protection mechanism. To mitigate, json_dumper.rb in gon now does escaping for XSS by default without relying on MultiJson.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-25739
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:07 UTC · Revision 1
Source evidence
An issue was discovered in the gon gem before gon-6.4.0 for Ruby. MultiJson does not honor the escape_mode parameter to escape fields as an XSS protection mechanism. To mitigate, json_dumper.rb in gon now does escaping for XSS by default without relying on MultiJson.
osv:CVE-2020-25739
Complete source record
{
"id": "1dfb913ca6c6783019a48acb59cbddec1ebe49278c6550ea03e36be0a099de33",
"url": "https://osv.dev/vulnerability/CVE-2020-25739",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-25739",
"summary": "An issue was discovered in the gon gem before gon-6.4.0 for Ruby. MultiJson does not honor the escape_mode parameter to escape fields as an XSS protection mechanism. To mitigate, json_dumper.rb in gon now does escaping for XSS by default without relying on MultiJson.",
"evidence": "osv:CVE-2020-25739",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2020-25739",
"aliases": [
"CVE-2020-25739",
"GHSA-78vq-9j56-wrfr"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/gazay/gon",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "fe3c7b2191a992386dc9edd37de5447a4e809bc7"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:gon_project:gon:*:*:*:*:*:ruby:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "6.4.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "fe3c7b2191a992386dc9edd37de5447a4e809bc7"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v6.3.2",
"v6.3.1",
"v6.2.1",
"v6.2.0",
"v6.1.0",
"v6.0.1",
"v6.0.0",
"v5.2.3",
"v5.2.2",
"v5.2.1",
"v5.2.0",
"v5.1.2",
"v5.1.1",
"v5.1.0",
"v5.0.4",
"v5.0.3",
"v5.0.2",
"v5.0.1",
"v5.0.0",
"v4.1.1",
"v4.1.0",
"v4.0.3",
"v4.0.2",
"v4.0.1",
"v4.0.0beta",
"v3.0.5",
"v3.0.4",
"v3.0.3",
"v3.0.2",
"v3.0.0",
"v2.3.0",
"v2.2.2",
"v2.2.0",
"v2.1.2",
"v2.1.0",
"v2.0.6",
"v2.0.5",
"v2.0.4",
"v2.0.3",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"v1.1.3",
"v1.1.2",
"v1.1.1",
"v1.1.0",
"v1.0.0",
"v0.3.0",
"v0.2.2",
"v0.2.1",
"v0.2.0",
"v0.1.1",
"v0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-25739.json"
}
}
],
"modified": "2026-10-20T10:52:54.292703116Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2020/09/msg00018.html",
"https://usn.ubuntu.com/4560-1/",
"https://github.com/gazay/gon/commit/fe3c7b2191a992386dc9edd37de5447a4e809bc7"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*"
],
"vendor_product": "canonical:ubuntu_linux",
"extracted_events": [
{
"range": [
{
"introduced": "18.04"
},
{
"last_affected": "18.04"
}
],
"source": "CPE_STRING"
}
]
},
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2020-25739",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 384017,
"published_at": "2020-09-23T14:15:12.947+00:00"
}