Skip to content
Heist/ feed
Back to feed
Critical

Apache Zeppelin: Interpreter download command does not escape malicious code injection

Type: advisorySources: OSV

Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-31866
Confirmed fixed CVEs
Not specified
Updated in this feed
5 Nov 2026, 03:34 UTC · Revision 1

Source evidence

Apache Zeppelin: Interpreter download command does not escape malicious code injection

core-osv · Original source

Published 9 Apr 2024, 16:09 UTC

Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

osv:CVE-2024-31866
Complete source record
{
  "id": "f8b7f4c702948c22480b99608be145a69816ee3fcb7540ebce7d110bffe4a03c",
  "url": "https://osv.dev/vulnerability/CVE-2024-31866",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Zeppelin: Interpreter download command does not escape malicious code injection",
    "summary": "Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.",
    "evidence": "osv:CVE-2024-31866",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2024-31866",
      "aliases": [
        "CVE-2024-31866",
        "GHSA-86jx-wr74-xr74"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/zeppelin",
              "type": "GIT",
              "events": [
                {
                  "introduced": "64f8baec7ca4e86bd88893415e07a8a0f1d133e7"
                },
                {
                  "fixed": "4419b4deeac67c0c7a1aeff388fa18ad6a086ddf"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0.8.2"
                      },
                      {
                        "fixed": "0.11.1"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StandardRange"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:zeppelin:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0.8.2"
                      },
                      {
                        "fixed": "0.11.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-31866.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:42.284604033Z",
      "provider": "osv",
      "references": [
        "https://repo.maven.apache.org/maven2",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/31xxx/CVE-2024-31866.json",
        "https://lists.apache.org/thread/jpkbq3oktopt34x2n5wnhzc2r1410ddd",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-31866",
        "https://github.com/apache/zeppelin/pull/4715"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-116"
        ],
        "cna_assigner": "apache",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/31xxx/CVE-2024-31866.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-31866",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 509900,
  "published_at": "2024-04-09T16:09:12.117+00:00"
}