Medium
Security advisory
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-6188
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 09:55 UTC · Revision 1
Source evidence
Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.
osv:CVE-2017-6188
Complete source record
{
"id": "b41c36a0b7fd7c9acfc39e0f8f168f8b83a3b41f3a8184415793d2c1947d071f",
"url": "https://osv.dev/vulnerability/CVE-2017-6188",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-6188",
"summary": "Munin before 2.999.6 has a local file write vulnerability when CGI graphs are enabled. Setting multiple upper_limit GET parameters allows overwriting any file accessible to the www-data user.",
"evidence": "osv:CVE-2017-6188",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2017-6188",
"aliases": [
"CVE-2017-6188"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/munin-monitoring/munin",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "3757f16bf453f172ca750403156029563405e840"
},
{
"introduced": "7d5499100e2e67863992e0ab4b484458cb1d6b5e"
},
{
"fixed": "05686a7a5c1c880cd7d3e4d15bb524930aa3798a"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:munin-monitoring:munin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.0.30.1"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:munin-monitoring:munin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.1.0"
},
{
"fixed": "2.999.9"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.999.8",
"2.999.7",
"debian/2.0.25-1",
"2.999.6",
"debian/2.0.29-1",
"2.999.5",
"debian/2.0.28-1",
"debian/2.0.27-1",
"2.999.4",
"debian/2.0.26-4",
"debian/2.0.26-3",
"debian/2.0.26-2",
"debian/2.0.26-1",
"2.1.12",
"debian/2.0.25-2",
"2.1.11",
"2.1.10",
"2.1.9",
"debian/2.0.24-1",
"2.1.1",
"2.0.23-1",
"2.0.22-1",
"2.1.8",
"2.1.6.1",
"2.1.7",
"debian/2.0.21-2",
"debian/2.0.21-1",
"2.1.6",
"2.0.19-3",
"2.0.19-2",
"2.1.4",
"2.1.3",
"2.0.19-1",
"2.0.18-1",
"2.0.17-3",
"2.0.17-2",
"2.1.2",
"2.0.17-1",
"debian/2.0.16-3",
"2.0.16-3",
"2.0.16-2",
"2.0.16-1",
"2.0.15-1",
"2.1.0",
"2.0.14-1",
"2.0.13-1",
"2.0.12-1",
"2.0.11.1-1",
"2.0.11-1",
"2.0.10-1",
"2.0.9-5",
"2.0.9-4",
"2.0.9-3",
"2.0.9-2",
"2.0.9-1",
"2.0.6-1",
"2.0.5-1",
"2.0.2-1",
"2.0.1-1",
"2.0.0-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-6188.json"
}
}
],
"modified": "2026-10-20T10:48:46.508525527Z",
"provider": "osv",
"references": [
"https://security.gentoo.org/glsa/201710-05",
"https://www.debian.org/security/2017/dsa-3794",
"https://bugs.debian.org/855705",
"https://github.com/munin-monitoring/munin/issues/721"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2017-6188",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 380332,
"published_at": "2017-02-22T19:59:00.293+00:00"
}